summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2017-10-01 06:13:58 +0000
committerPatrick Lauer <patrick@gentoo.org>2017-10-01 06:14:14 +0000
commitb1c4789235e115a3f57071522a255f302c469909 (patch)
tree05769916c3e2d0b0e4971f5d5819fd4f1a4b5492
parentdev-qt/qtwebview: new pacakge (diff)
downloadgentoo-b1c4789235e115a3f57071522a255f302c469909.tar.gz
gentoo-b1c4789235e115a3f57071522a255f302c469909.tar.bz2
gentoo-b1c4789235e115a3f57071522a255f302c469909.zip
dev-python/wsgiproxy2: Bump
Package-Manager: Portage-2.3.10, Repoman-2.3.3
-rw-r--r--dev-python/wsgiproxy2/Manifest1
-rw-r--r--dev-python/wsgiproxy2/wsgiproxy2-0.4.4.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/wsgiproxy2/Manifest b/dev-python/wsgiproxy2/Manifest
index 22f8f8424cd7..d9f5fc4f8de9 100644
--- a/dev-python/wsgiproxy2/Manifest
+++ b/dev-python/wsgiproxy2/Manifest
@@ -1,2 +1,3 @@
DIST WSGIProxy2-0.4.1.zip 18437 SHA256 70232dd33ffc742b2c1e8d7573a61035a1b7fcd92dc0c761e283de515ab94f69 SHA512 794cf74d47366ab80f03ef311cd77258b4152f266cabf662b3eccb0f706f246d6d4407f495432ed32520ed69ecf3cb5ae05ef8a50e7f59062c6ef7395d8c9eec WHIRLPOOL 08c784bb15a7a1da21ea38201781e502ad3f5515658a441f7671f2ba2c971966f320e52f223b6d47feedb35cefb4c513be454114f5d2635a78ec991b2e1a288f
DIST WSGIProxy2-0.4.2.zip 18817 SHA256 a4b236fac5d4a2b51d9b3ed34cbe0d01aae173dce0ab9877f225b1dcdb4a6e8e SHA512 3dd750263485ceb644373d8ea9692c9a46126a1ed7cd640feba7d42b0fe618e290dcae2f76dc83be77de34211ac473f5a1496a8309e3fcc64982e9642af786fb WHIRLPOOL e585abf60d7f3bfe60d700dca99887efe0616f4cdb43de2edabe3b53b8b4f7eaf730c465d1a95618ac4ff0c99b488fa241400eaecd69ca8cd7c2e2012fbbcd51
+DIST WSGIProxy2-0.4.4.tar.gz 16475 SHA256 f9347ba1405ebe4ea614a290f10d44577f3fdc644e8ad2c9e10392c46416a398 SHA512 6ae9fca65fe80f52924f42b26b447631e8c278f517ababc23d26e5f8598d6d9b7975197ec74faf64f2e051824366ac14c5db5727a014a187c70a1b4604105b42 WHIRLPOOL 03c86eda1c20a28b6adbadfac8d7d717c8bc184313309db1377dea0a8b16a10beab6dca08413e5ff31ca6e7ed5cebf43851d79c18714fe5142405c96ff03ffca
diff --git a/dev-python/wsgiproxy2/wsgiproxy2-0.4.4.ebuild b/dev-python/wsgiproxy2/wsgiproxy2-0.4.4.ebuild
new file mode 100644
index 000000000000..1756e680ae96
--- /dev/null
+++ b/dev-python/wsgiproxy2/wsgiproxy2-0.4.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+MY_PN="WSGIProxy2"
+
+DESCRIPTION="HTTP proxying tools for WSGI apps"
+HOMEPAGE="http://pythonpaste.org/wsgiproxy/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/webob[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ >=dev-python/webtest-2.0.17[${PYTHON_USEDEP}]
+ dev-python/socketpool[${PYTHON_USEDEP}]
+ dev-python/restkit[$(python_gen_usedep python2_7)] )"
+# Tests needing restkit are skipped under py3
+# Testing also revealed the suite needs latest webtest
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_compile_all() {
+ if use doc; then
+ cd docs || die
+ sphinx-build -b html -d _build/doctrees . _build/html
+ fi
+}
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}