summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Pavljuchenkov (SpiderX) <spiderx@spiderx.dp.ua>2018-10-27 00:41:25 +0300
committerMichał Górny <mgorny@gentoo.org>2018-11-03 10:03:41 +0100
commitb1ebede50482abc431ef89fd3977582be7e4cb0e (patch)
treecb38c16fb137599b1f69a9c60c8ae1a651dcf664
parentx11-misc/libinput-gestures: drop old 2.36 (diff)
downloadgentoo-b1ebede50482abc431ef89fd3977582be7e4cb0e.tar.gz
gentoo-b1ebede50482abc431ef89fd3977582be7e4cb0e.tar.bz2
gentoo-b1ebede50482abc431ef89fd3977582be7e4cb0e.zip
x11-misc/libinput-gestures: version bump 2.39
Signed-off-by: Vladimir Pavljuchenkov <spiderx@spiderx.dp.ua> Package-Manager: Portage-2.3.49, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/10245 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--x11-misc/libinput-gestures/Manifest1
-rw-r--r--x11-misc/libinput-gestures/libinput-gestures-2.39.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/x11-misc/libinput-gestures/Manifest b/x11-misc/libinput-gestures/Manifest
index 244050caf616..ebc82bf47eb3 100644
--- a/x11-misc/libinput-gestures/Manifest
+++ b/x11-misc/libinput-gestures/Manifest
@@ -1 +1,2 @@
DIST libinput-gestures-2.38.tar.gz 17054 BLAKE2B 037d095674df9b00c9d23762745d35beaab03d0f5b361030a9177f84c540ef2ef45fb6fa4b9fe80a6500c81a8973aac46019931d8a548b02a6527ba09ca1fc13 SHA512 3152bcb0fd78551be14dda23fdce9f9216fc56e7a2dc4734b73949b4bd9c87fe6c9e2fc95f65a328b46c577abc05889a3a6290c6eb9390a94d9eb254c2fc7550
+DIST libinput-gestures-2.39.tar.gz 18028 BLAKE2B f7d24a1ca8a6ba7064359d3f1c4e1cc72419205d94c9da7efc85b1fa0561f8353a50e126b6ec15cd79f6ef6c82b5d1ed94d44f0af6fcfc21eb2644695dd66337 SHA512 5aa54c9da01de76e279924bc2840b704f163512e06734fee1fa37e6905c33fa2aa734f4bfef6e8bc75a654f0345dfd8928be298d880229cc47be791a65ba1927
diff --git a/x11-misc/libinput-gestures/libinput-gestures-2.39.ebuild b/x11-misc/libinput-gestures/libinput-gestures-2.39.ebuild
new file mode 100644
index 000000000000..ebd4d9f424c9
--- /dev/null
+++ b/x11-misc/libinput-gestures/libinput-gestures-2.39.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4..7} )
+
+inherit gnome2-utils python-single-r1
+
+DESCRIPTION="Actions gestures on your touchpad using libinput"
+HOMEPAGE="https://github.com/bulletmark/libinput-gestures"
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/bulletmark/${PN}.git"
+else
+ SRC_URI="https://github.com/bulletmark/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/libinput-1.8.0
+ x11-misc/xdotool
+ x11-misc/wmctrl"
+DEPEND=">=dev-libs/libinput-1.8.0
+ dev-util/desktop-file-utils"
+
+src_prepare() {
+ default
+
+ # Fix docdir installation path
+ sed '/^DOCDIR/s@$NAME@${PF}@' -i libinput-gestures-setup || die
+}
+
+src_test() { :; }
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+
+ elog "You must be in the input group to read the touchpad device."
+
+ if ! has_version x11-libs/gtk+:3 ; then
+ elog "${PN}-setup script supports Gnome 3 via x11-libs/gtk+:3."
+ fi
+ if ! has_version kde-plasma/kde-cli-tools:5 ; then
+ elog "${PN}-setup script supports Plasma 5 via kde-plasma/kde-cli-tools:5."
+ fi
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}