summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-08-18 01:10:56 -0400
committerTim Harder <radhermit@gentoo.org>2016-08-18 01:10:56 -0400
commitb2a80b0e1f5841d7870296deaff1c55ffbfdcacb (patch)
treefab2e662151761472ff7e7b1759873dfa3d6c397
parentapp-vim/gentoo-syntax: remove old (diff)
downloadgentoo-b2a80b0e1f5841d7870296deaff1c55ffbfdcacb.tar.gz
gentoo-b2a80b0e1f5841d7870296deaff1c55ffbfdcacb.tar.bz2
gentoo-b2a80b0e1f5841d7870296deaff1c55ffbfdcacb.zip
app-vim/gnupg: version bump to 2.6
-rw-r--r--app-vim/gnupg/Manifest1
-rw-r--r--app-vim/gnupg/gnupg-2.6.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/app-vim/gnupg/Manifest b/app-vim/gnupg/Manifest
index c2403e656235..8a23e23b7376 100644
--- a/app-vim/gnupg/Manifest
+++ b/app-vim/gnupg/Manifest
@@ -1 +1,2 @@
DIST gnupg-2.5.tar.bz2 10149 SHA256 a04219ec0d7d113e4e9de8846388ffe028888e9ea34dbedb38822dfb21f204a4 SHA512 45800bb39cb0a692bc68654e93935008d1fa6a14ce942d87e193f65d243796e159a4624013b1e98204ce8e99ab6a6588c9ea9db20b99f12e102b4733e178f78d WHIRLPOOL 3f6aa257057038cfe51b1319028e554f11b19c0bd269ae303894993cbe262167ff843c373f60cf3bdbd7b1fe23cd74ef4b8d402135fe60aa8a1e5146f29965ac
+DIST gnupg-2.6.tar.bz2 12074 SHA256 0c35d9e7026da11e236759b4b6895b7a5e56dce1849a433cc03ac11aa246eeed SHA512 1b7307954aad751006286edebb80767951b9bd9a8eff4c4a57fa6030cb442ceca12730a82c76a2181e1da19cc4cc8be21ccd4f8a21817aedf42785d8ff4b61ac WHIRLPOOL fff1d6bf8d5c54490e76a2dda3600fcab6db1eb3cc15f7baec2e8697f24e43d162c17a92d7e949a1b1148efeae2e40c6c38e3c08bacd2397bd1d86d6cda00e0e
diff --git a/app-vim/gnupg/gnupg-2.6.ebuild b/app-vim/gnupg/gnupg-2.6.ebuild
new file mode 100644
index 000000000000..583108037acf
--- /dev/null
+++ b/app-vim/gnupg/gnupg-2.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="transparent editing of gpg encrypted files"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3645"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="app-crypt/gnupg"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ default
+
+ # There's good documentation included with the script, but it's not
+ # in a helpfile. Since there's rather too much information to include
+ # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+ mkdir doc
+ sed -e '/" Section: Plugin header.\+$/,9999d' -e 's/^" \?//' \
+ -e 's/\(Name:\s\+\)\([^.]\+\)\.vim/\1*\2.txt*/' \
+ plugin/${PN}.vim \
+ > doc/${PN}.txt
+}