summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-06-27 20:49:12 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-06-28 04:00:14 +0000
commitb2b55cac12516c971e819d1d9087361de51d41c7 (patch)
tree1aa139862d4f4f0917607882dce79b01265261d6
parentsci-mathematics/pymc3: version bump (diff)
downloadgentoo-b2b55cac12516c971e819d1d9087361de51d41c7.tar.gz
gentoo-b2b55cac12516c971e819d1d9087361de51d41c7.tar.bz2
gentoo-b2b55cac12516c971e819d1d9087361de51d41c7.zip
dev-python/thriftpy: initial import
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--dev-python/thriftpy/Manifest1
-rw-r--r--dev-python/thriftpy/metadata.xml19
-rw-r--r--dev-python/thriftpy/thriftpy-0.3.9.ebuild28
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/thriftpy/Manifest b/dev-python/thriftpy/Manifest
new file mode 100644
index 000000000000..1d4364884860
--- /dev/null
+++ b/dev-python/thriftpy/Manifest
@@ -0,0 +1 @@
+DIST thriftpy-0.3.9.tar.gz 208164 SHA256 309e57d97b5bfa01601393ad4f245451e989d6206a59279e56866b264a99796d SHA512 ad2b7f568db47f7f26235fc5fb6180c974eb6738f154461860c7329d263252ee627b979098c3e9ffe8ed42a0fb08a9110a6842a923ac800166d80a23d4e6a3cb WHIRLPOOL d371078349d345f01537ffc63eb924507921819d6e9c1577d0b522067cb1b36a8feae2211860c51c17b5e5fcf5c37f0c65c46b8d71687a114fb7c31667feb809
diff --git a/dev-python/thriftpy/metadata.xml b/dev-python/thriftpy/metadata.xml
new file mode 100644
index 000000000000..33592bf9bb0d
--- /dev/null
+++ b/dev-python/thriftpy/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Thrift is a software framework for the development of reliable and
+ performant communication and data serialization. It combines a software
+ stack with a code generation to build services that operate seamlessly
+ across a number of different development languages.
+ This is a pure Python implementation of Apache Thrift.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">thriftpy</remote-id>
+ <remote-id type="github">eleme/thriftpy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/thriftpy/thriftpy-0.3.9.ebuild b/dev-python/thriftpy/thriftpy-0.3.9.ebuild
new file mode 100644
index 000000000000..d0d687f397ce
--- /dev/null
+++ b/dev-python/thriftpy/thriftpy-0.3.9.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python implementation of Apache Thrift"
+HOMEPAGE="https://thriftpy.readthedocs.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/toro[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/cython-0.23[${PYTHON_USEDEP}]
+"