summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-04-04 16:57:34 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-04-04 17:12:03 -0700
commitb3686ff7aee4ece15744169e0feda1ca0578e019 (patch)
treeddc1f5e28f1a89487d1161bf3a615300d781df69
parentdev-go/gox: remove old (diff)
downloadgentoo-b3686ff7aee4ece15744169e0feda1ca0578e019.tar.gz
gentoo-b3686ff7aee4ece15744169e0feda1ca0578e019.tar.bz2
gentoo-b3686ff7aee4ece15744169e0feda1ca0578e019.zip
media-libs/flac: switch to CPU_FLAGS_PPC
--enable-altivec prevented flac from compiling on G4/G5 due to misdetection of vsx Adding proper flag allows to compile with altivec but without vsx. Closes: https://bugs.gentoo.org/701308 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--media-libs/flac/flac-1.3.3.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/media-libs/flac/flac-1.3.3.ebuild b/media-libs/flac/flac-1.3.3.ebuild
index b3aea9e2746a..0a616c50a7d7 100644
--- a/media-libs/flac/flac-1.3.3.ebuild
+++ b/media-libs/flac/flac-1.3.3.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://downloads.xiph.org/releases/${PN}/${P}.tar.xz"
LICENSE="BSD FDL-1.2 GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="altivec +cxx debug ogg cpu_flags_x86_sse static-libs"
+IUSE="+cxx debug ogg cpu_flags_ppc_altivec cpu_flags_ppc_vsx cpu_flags_x86_sse static-libs"
RDEPEND="ogg? ( >=media-libs/libogg-1.3.0[${MULTILIB_USEDEP}] )"
DEPEND="${RDEPEND}
@@ -30,7 +30,8 @@ multilib_src_configure() {
--disable-examples
--disable-xmms-plugin
$([[ ${CHOST} == *-darwin* ]] && echo "--disable-asm-optimizations")
- $(use_enable altivec)
+ $(use_enable cpu_flags_ppc_altivec altivec)
+ $(use_enable cpu_flags_ppc_vsx vsx)
$(use_enable cpu_flags_x86_sse sse)
$(use_enable cxx cpplibs)
$(use_enable debug)