summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-04-22 07:16:13 +0200
committerHans de Graaff <graaff@gentoo.org>2019-04-22 07:16:13 +0200
commitb368a9646a03d1084a009e568559a29184603c88 (patch)
tree48ac38bc620bc2d99b59818e84a44e3cf948d2a3
parentnet-libs/libupnpp: remove old (diff)
downloadgentoo-b368a9646a03d1084a009e568559a29184603c88.tar.gz
gentoo-b368a9646a03d1084a009e568559a29184603c88.tar.bz2
gentoo-b368a9646a03d1084a009e568559a29184603c88.zip
dev-ruby/rspec-expectations: add 3.8.3
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
-rw-r--r--dev-ruby/rspec-expectations/Manifest1
-rw-r--r--dev-ruby/rspec-expectations/rspec-expectations-3.8.3.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-ruby/rspec-expectations/Manifest b/dev-ruby/rspec-expectations/Manifest
index 6ca8131fccb5..a7561379b734 100644
--- a/dev-ruby/rspec-expectations/Manifest
+++ b/dev-ruby/rspec-expectations/Manifest
@@ -1,3 +1,4 @@
DIST rspec-expectations-2.99.2-git.tgz 106884 BLAKE2B 5b31c8681306d5c688f62fc3fc6adf7be6cabad6df6fd16195c71787d73495924233d793633fa041a94d796f63c9ff97c58e6f4a75bdc09dfbe56e770bb6a5c9 SHA512 6042cafe225b2b16df458c7bf69e1694b637afcac6f6195e35a0be199432610457ccaa3e7e4bd114b27a7a6c3d530d94f4c0603c65f469cbadc55bd3f75b6f3a
DIST rspec-expectations-3.7.0-git.tgz 194071 BLAKE2B 67c8db15c43cc1141b19c6eb99390eaaf2535ec03f0fdc7b05576daa463d252f56ff251d40f5771726ee6451d57eef206c893f2593b01d413b5d96cdf21f0daf SHA512 bdd3222089299e9bfdd6f17a2b8af81d5e695290a3ce976630d586d51ff2df5baf76a3887b8adb31294bd6623ba85f8c2a4a31ac520046515aeeb81fa3a1bd5a
DIST rspec-expectations-3.8.2-git.tgz 198952 BLAKE2B 6952f895251f26f8a1b7746b277fc92b296e78fb23b8f581e90f649ccc28e21e0a695f87b012b4925becfcda8f8876414f74a826c75bdfa5114092849bbfe525 SHA512 d374f7add45d2b6ce607c1a068e3e0970f902a0edf96ec891bd618dd17253878c1e0b625296ff12a6dc35103651bbfbcfd1a1b444f94e08eae2680e32853a198
+DIST rspec-expectations-3.8.3-git.tgz 200239 BLAKE2B 88295c7df00a99486bb19ae37ee74a857a087afdb4c14eb6db8c343e639ef322c45ab9de25b0c70707a9f17cbc81c47baff8b7695fc6a1440de5509b1508cb1f SHA512 328b3403e7ac2864ed6ad1a196ca24df6693797e35525559f2082c7e1c161d60da7776ca1a68a82364a7ea55115ac2c12ebf6af8486ef88757a4818a9683ae80
diff --git a/dev-ruby/rspec-expectations/rspec-expectations-3.8.3.ebuild b/dev-ruby/rspec-expectations/rspec-expectations-3.8.3.ebuild
new file mode 100644
index 000000000000..647c42d8500a
--- /dev/null
+++ b/dev-ruby/rspec-expectations/rspec-expectations-3.8.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem eapi7-ver
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="https://github.com/rspec/rspec-expectations"
+SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+SUBVERSION="$(ver_cut 1-2)"
+
+ruby_add_rdepend ">=dev-ruby/diff-lcs-1.2.0 <dev-ruby/diff-lcs-2
+ =dev-ruby/rspec-support-${SUBVERSION}*"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/rspec-mocks-3.2.0:3
+ >=dev-ruby/rspec-support-3.5.0:3
+ )"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Remove the Gemfile to avoid running through 'bundle exec'
+ rm -f Gemfile || die
+
+ # fix up the gemspecs
+ sed -i \
+ -e '/git ls/d' \
+ -e '/add_development_dependency/d' \
+ "${RUBY_FAKEGEM_GEMSPEC}" || die
+}