summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-08 13:38:54 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 16:54:22 +0100
commitb37173851bce8c0b8d6edd3ba7c881add7245d82 (patch)
tree837f521b8ea62e8627dc8b67bdde0b6d3ea9885c
parentsci-chemistry/pdb2pqr: Switch to python-single-r1 (diff)
downloadgentoo-b37173851bce8c0b8d6edd3ba7c881add7245d82.tar.gz
gentoo-b37173851bce8c0b8d6edd3ba7c881add7245d82.tar.bz2
gentoo-b37173851bce8c0b8d6edd3ba7c881add7245d82.zip
www-apps/trac-mercurial: Switch to python-single-r1, due to trac dep
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--www-apps/trac-mercurial/trac-mercurial-0.12.0.29_pre10899-r2.ebuild (renamed from www-apps/trac-mercurial/trac-mercurial-0.12.0.29_pre10899-r1.ebuild)10
-rw-r--r--www-apps/trac-mercurial/trac-mercurial-1.0.0.3_pre20130206-r1.ebuild10
2 files changed, 12 insertions, 8 deletions
diff --git a/www-apps/trac-mercurial/trac-mercurial-0.12.0.29_pre10899-r1.ebuild b/www-apps/trac-mercurial/trac-mercurial-0.12.0.29_pre10899-r2.ebuild
index e661cc957b68..705c196994e6 100644
--- a/www-apps/trac-mercurial/trac-mercurial-0.12.0.29_pre10899-r1.ebuild
+++ b/www-apps/trac-mercurial/trac-mercurial-0.12.0.29_pre10899-r2.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+DISTUTILS_SINGLE_IMPL=1
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1
@@ -19,8 +20,9 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=">=www-apps/trac-0.12[${PYTHON_USEDEP}]
- >=dev-vcs/mercurial-1.1[${PYTHON_USEDEP}]"
+RDEPEND=">=www-apps/trac-0.12[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-vcs/mercurial-1.1[${PYTHON_MULTI_USEDEP}]
+ ')"
S="${WORKDIR}/${MY_P}"
diff --git a/www-apps/trac-mercurial/trac-mercurial-1.0.0.3_pre20130206-r1.ebuild b/www-apps/trac-mercurial/trac-mercurial-1.0.0.3_pre20130206-r1.ebuild
index 9b4f678dd53a..6aa50c5b940c 100644
--- a/www-apps/trac-mercurial/trac-mercurial-1.0.0.3_pre20130206-r1.ebuild
+++ b/www-apps/trac-mercurial/trac-mercurial-1.0.0.3_pre20130206-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+DISTUTILS_SINGLE_IMPL=1
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1 mercurial
@@ -20,8 +21,9 @@ SLOT="0"
# KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=">=www-apps/trac-1.0[${PYTHON_USEDEP}]
- >=dev-vcs/mercurial-1.1[${PYTHON_USEDEP}]"
+RDEPEND=">=www-apps/trac-1.0[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-vcs/mercurial-1.1[${PYTHON_MULTI_USEDEP}]
+ ')"
S="${WORKDIR}/${MY_P}"