summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-12-19 16:55:18 +0100
committerPacho Ramos <pacho@gentoo.org>2015-12-19 17:16:46 +0100
commitb3caeafc8448559f828e0bfa709e854f029ad2ef (patch)
treed259b63057f912913ae3b8c3a1b60d22823d9492
parentdev-util/regexxer: Fix building with latest glibmm/libsigc++ (diff)
downloadgentoo-b3caeafc8448559f828e0bfa709e854f029ad2ef.tar.gz
gentoo-b3caeafc8448559f828e0bfa709e854f029ad2ef.tar.bz2
gentoo-b3caeafc8448559f828e0bfa709e854f029ad2ef.zip
games-board/hexxagon: Fix building with latest glibmm/libsigc++
Package-Manager: portage-2.2.26
-rw-r--r--games-board/hexxagon/hexxagon-1.0.2.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/games-board/hexxagon/hexxagon-1.0.2.ebuild b/games-board/hexxagon/hexxagon-1.0.2.ebuild
index 08f767a38b56..1af79c114b63 100644
--- a/games-board/hexxagon/hexxagon-1.0.2.ebuild
+++ b/games-board/hexxagon/hexxagon-1.0.2.ebuild
@@ -3,7 +3,7 @@
# $Id$
EAPI=5
-inherit eutils games
+inherit eutils flag-o-matic games
DESCRIPTION="Clone of the original DOS game"
HOMEPAGE="http://www.nesqi.se/"
@@ -20,6 +20,10 @@ RDEPEND="dev-cpp/glibmm:2
DEPEND="${RDEPEND}
virtual/pkgconfig"
+src_prepare() {
+ append-cxxflags -std=c++11
+}
+
src_install() {
emake DESTDIR="${D}" install
newicon images/board_N_2.xpm ${PN}.xpm