summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-02-19 19:41:38 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-19 19:44:39 +0100
commitb40760bd69c57dae5c57650ee8507e5ac0d54b1c (patch)
treed7f9eda41d0c3bea0672d71435d21d4bf314b024
parentsci-biology/embassy-vienna: Remove old (diff)
downloadgentoo-b40760bd69c57dae5c57650ee8507e5ac0d54b1c.tar.gz
gentoo-b40760bd69c57dae5c57650ee8507e5ac0d54b1c.tar.bz2
gentoo-b40760bd69c57dae5c57650ee8507e5ac0d54b1c.zip
sci-biology/emboss: Remove old
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3937
-rw-r--r--eclass/emboss-r1.eclass134
-rw-r--r--sci-biology/emboss/emboss-6.6.0.ebuild67
2 files changed, 0 insertions, 201 deletions
diff --git a/eclass/emboss-r1.eclass b/eclass/emboss-r1.eclass
deleted file mode 100644
index 2b58de68a2cd..000000000000
--- a/eclass/emboss-r1.eclass
+++ /dev/null
@@ -1,134 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-# @ECLASS: emboss-r1.eclass
-# @MAINTAINER:
-# sci-biology@gentoo.org
-# jlec@gentoo.org
-# ted.tanberry@gmail.com
-# @AUTHOR:
-# Original author: Author Olivier Fisette <ofisette@gmail.com>
-# Next gen author: Justin Lecher <jlec@gentoo.org>
-# Next gen author: Ted Tanberry <ted.tanberry@gmail.com>
-# @BLURB: Use this to easy install EMBOSS and EMBASSY programs (EMBOSS add-ons).
-# @DESCRIPTION:
-# The inheriting ebuild must set at least EAPI=5 and provide EBO_DESCRIPTION before the inherit line.
-# KEYWORDS should be set. Additionally "(R|P)DEPEND"encies and other standard
-# ebuild variables can be extended (FOO+=" bar").
-#
-# Example:
-#
-# EAPI="5"
-#
-# EBO_DESCRIPTION="applications from the CBS group"
-#
-# inherit emboss-r1
-
-# @ECLASS-VARIABLE: EBO_DESCRIPTION
-# @DEFAULT_UNSET
-# @DESCRIPTION:
-# Should be set. Completes the generic description of the embassy module as follows:
-#
-# EMBOSS integrated version of ${EBO_DESCRIPTION}, e.g.
-#
-# "EMBOSS integrated version of applications from the CBS group"
-#
-# Defaults to the upstream name of the module.
-
-# @ECLASS-VARIABLE: EBO_EXTRA_ECONF
-# @DEFAULT_UNSET
-# @DESCRIPTION:
-# Extra config options passed to econf.
-
-case ${EAPI:-0} in
- 5) ;;
- *) die "this eclass doesn't support < EAPI 5" ;;
-esac
-
-inherit autotools-utils eutils flag-o-matic
-
-HOMEPAGE="http://emboss.sourceforge.net/"
-LICENSE="LGPL-2 GPL-2"
-
-SLOT="0"
-IUSE="mysql pdf png postgres static-libs X"
-
-DEPEND="
- dev-libs/expat
- dev-libs/libpcre:3
- sci-libs/plplot
- sys-libs/zlib
- mysql? ( virtual/mysql )
- pdf? ( media-libs/libharu )
- png? ( media-libs/gd[png] )
- postgres? ( dev-db/postgresql:= )
- X? ( x11-libs/libXt )"
-RDEPEND="${DEPEND}"
-
-if [[ ${PN} == embassy-* ]]; then
- EMBASSY_PACKAGE=yes
- # The EMBASSY package name, retrieved from the inheriting ebuild's name
- EN=${PN:8}
- # The full name and version of the EMBASSY package (excluding the Gentoo
- # revision number)
- EF=$(echo ${EN} | tr "[:lower:]" "[:upper:]")-${PV}
- : ${EBO_DESCRIPTION:=${EN}}
- DESCRIPTION="EMBOSS integrated version of ${EBO_DESCRIPTION}"
- SRC_URI="ftp://emboss.open-bio.org/pub/EMBOSS/${EF}.tar.gz -> embassy-${EN}-${PVR}.tar.gz"
- DEPEND+=" >=sci-biology/emboss-6.6.0[mysql=,pdf=,png=,postgres=,static-libs=,X=]"
-
- S="${WORKDIR}"/${EF}
-fi
-
-# @FUNCTION: emboss-r1_src_prepare
-# @DESCRIPTION:
-# Does the following things
-#
-# 1. Renames configure.in to configure.ac, if possible
-# 2. Applies ${PATCHES[@]} and runs autotools via autotools-utils.eclass
-#
-
-emboss-r1_src_prepare() {
- if [[ -e configure.in ]]; then
- mv configure.{in,ac} || die
- fi
-
- autotools-utils_src_prepare
-}
-
-# @FUNCTION: emboss-r1_src_configure
-# @DESCRIPTION:
-# runs econf with following options.
-#
-# $(use_with X x)
-# $(use_with png pngdriver)
-# $(use_with pdf hpdf)
-# $(use_with mysql mysql)
-# $(use_with postgres postgresql)
-# $(use_enable static-libs static)
-# --enable-large
-# --without-java
-# --enable-systemlibs
-# ${EBO_EXTRA_ECONF}
-
-emboss-r1_src_configure() {
- local myeconfargs=(
- $(use_with X x)
- $(use_with png pngdriver "${EPREFIX}/usr")
- $(use_with pdf hpdf "${EPREFIX}/usr")
- $(use_with mysql mysql "${EPREFIX}/usr/bin/mysql_config")
- $(use_with postgres postgresql "${EPREFIX}/usr/bin/pg_config")
- --enable-large
- --without-java
- --enable-systemlibs
- ${EBO_EXTRA_ECONF}
- )
-
- [[ ${EMBASSY_PACKAGE} == yes ]] && \
- append-cppflags "-I${EPREFIX}/usr/include/emboss"
-
- autotools-utils_src_configure
-}
-
-EXPORT_FUNCTIONS src_prepare src_configure
diff --git a/sci-biology/emboss/emboss-6.6.0.ebuild b/sci-biology/emboss/emboss-6.6.0.ebuild
deleted file mode 100644
index 8b1d211efd1a..000000000000
--- a/sci-biology/emboss/emboss-6.6.0.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-AUTOTOOLS_AUTORECONF=1
-
-inherit autotools-utils emboss-r1 eutils readme.gentoo-r1
-
-DESCRIPTION="The European Molecular Biology Open Software Suite - A sequence analysis package"
-SRC_URI="ftp://emboss.open-bio.org/pub/EMBOSS/EMBOSS-${PV}.tar.gz"
-
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE+=" minimal"
-LICENSE+=" Apache-2.0 GPL-3+ CC-BY-3.0"
-
-RDEPEND+="!games-action/xbomber
- !sys-devel/cons"
-PDEPEND+="
- !minimal? (
- sci-biology/aaindex
- sci-biology/cutg
- sci-biology/primer3
- sci-biology/prints
- sci-biology/prosite
- sci-biology/rebase
- )"
-
-S="${WORKDIR}"/EMBOSS-${PV}
-
-DOCS=( ChangeLog AUTHORS NEWS THANKS FAQ )
-
-PATCHES=(
- "${FILESDIR}"/${P}_fix-build-system.patch
- "${FILESDIR}"/${P}_FORTIFY_SOURCE-fix.patch
- "${FILESDIR}"/${P}_plplot-declarations.patch
- "${FILESDIR}"/${P}_qa-implicit-declarations.patch
-)
-
-src_install() {
- # Use autotools-utils_* to remove useless *.la files
- autotools-utils_src_install
-
- readme.gentoo_create_doc
-
- # Install env file for setting libplplot and acd files path.
- cat > 22emboss <<- EOF
- # ACD files location
- EMBOSS_ACDROOT="${EPREFIX}/usr/share/EMBOSS/acd"
- EMBOSS_DATA="${EPREFIX}/usr/share/EMBOSS/data"
- EOF
- doenvd 22emboss
-
- # Remove useless dummy files
- find "${ED}"/usr/share/EMBOSS -name dummyfile -delete || die "Failed to remove dummy files."
-
- # Move the provided codon files to a different directory. This will avoid
- # user confusion and file collisions on case-insensitive file systems (see
- # bug #115446). This change is documented in "README.gentoo".
- mv "${ED}"/usr/share/EMBOSS/data/CODONS{,.orig} || \
- die "Failed to move CODON directory."
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-}