summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-07-20 22:43:31 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-07-20 22:43:31 +0900
commitb417eee35105f6514e13c8e33061d1d1a1b06faa (patch)
tree3386c0caa18954c40874cfb6150428f931e17a1a
parentapp-emacs/yc: update to EAPI 6 (diff)
downloadgentoo-b417eee35105f6514e13c8e33061d1d1a1b06faa.tar.gz
gentoo-b417eee35105f6514e13c8e33061d1d1a1b06faa.tar.bz2
gentoo-b417eee35105f6514e13c8e33061d1d1a1b06faa.zip
app-emacs/yc: new upstream release
Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--app-emacs/yc/Manifest1
-rw-r--r--app-emacs/yc/yc-5.2.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-emacs/yc/Manifest b/app-emacs/yc/Manifest
index 2bc1bd6320a0..3c8baca4814f 100644
--- a/app-emacs/yc/Manifest
+++ b/app-emacs/yc/Manifest
@@ -1 +1,2 @@
DIST yc-4.0.13.tar.gz 43916 SHA256 5afd06ea819bbf20f5cbfbcd3c60eb58a50b2ef093defc4c93bfdf8ab69444f3 SHA512 2b5430766bbdbc77a0ec3aba6d51478ff91186a257e75a2a3af25a885bbddbf7180fbdf3b0876c1a65c149060bb754a44f77bb399c43cc666bd0add40226ca32 WHIRLPOOL fcd0fbb6729f42cf752a4d590357202ea54763c243e5e29d9f6a9676e420e1b501c1579e0230b0e59d88c15cc7f106c8c1d32effd7411e708bada5f68f3dd380
+DIST yc-5.2.1.el.gz 33305 SHA256 45854b3f51cf74b97c4ed0dd11b0f4bd2a96b78f59b7614d43fea85f9884fd84 SHA512 11c8d63a9f6cb94118a00976518949ab50496f8b8f994a8e1c352be5deefc549540935e0727b036c2b3c493366cfb8c47f040fcc425174b6668ec9f5e8d499dc WHIRLPOOL 00ef278c83e209ecd0a7940a26a105d8dfbd868e6eeb9b1525fcd0f5e8bae8aa0aafd1ba1dc8012facc83347fa8b059d36e9c5c45c26c3013bd80abb958ebcc3
diff --git a/app-emacs/yc/yc-5.2.1.ebuild b/app-emacs/yc/yc-5.2.1.ebuild
new file mode 100644
index 000000000000..eb6992a1aa20
--- /dev/null
+++ b/app-emacs/yc/yc-5.2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit elisp
+
+DESCRIPTION="Yet another Canna client on Emacsen"
+HOMEPAGE="http://www.ceres.dti.ne.jp/~knak/yc.html"
+SRC_URI="http://www.ceres.dti.ne.jp/~knak/${P}.el.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="app-i18n/canna"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp_src_install
+
+ dodoc "${FILESDIR}"/sample.{dot.emacs,hosts.canna}
+}
+
+pkg_postinst() {
+ elisp_pkg_postinst
+
+ elog "See the sample.dot.emacs in ${EPREFIX}/usr/share/doc/${PF}."
+ elog
+ elog "And If you use unix domain socket for connecting the canna server,"
+ elog "please confirm that there's *no* following line in your ~/.emacs:"
+ elog ' (setq yc-server-host "localhost")'
+ elog
+ elog "If you use inet domain socket for connecting the canna server,"
+ elog "please modify as following in ${EPREFIX}/etc/conf.d/canna:"
+ elog ' CANNASERVER_OPTS="-inet"'
+ elog
+ elog "And create ${EPREFIX}/etc/hosts.canna."
+ elog "See the sample.hosts.canna in ${EPREFIX}/usr/share/doc/${PF}."
+}