summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-01 19:47:16 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-01 19:47:37 +0100
commitb41f42a861661c6ba39c431961df204a4c19237e (patch)
tree32038a8be358655dfeaeeebf394990eec60e74fb
parentdev-ml/findlib: remove old (diff)
downloadgentoo-b41f42a861661c6ba39c431961df204a4c19237e.tar.gz
gentoo-b41f42a861661c6ba39c431961df204a4c19237e.tar.bz2
gentoo-b41f42a861661c6ba39c431961df204a4c19237e.zip
dev-ml/findlib: revbump to avoid installing ocamlbuild META file
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--dev-ml/findlib/files/externalmeta2.patch16
-rw-r--r--dev-ml/findlib/findlib-1.6.1-r1.ebuild76
2 files changed, 92 insertions, 0 deletions
diff --git a/dev-ml/findlib/files/externalmeta2.patch b/dev-ml/findlib/files/externalmeta2.patch
new file mode 100644
index 000000000000..f8e7a5a44a50
--- /dev/null
+++ b/dev-ml/findlib/files/externalmeta2.patch
@@ -0,0 +1,16 @@
+Avoid installing META files for labltk, camlp4 and ocamlbuild: Those are provided by their
+respective packages now.
+
+Index: findlib-1.5.5/configure
+===================================================================
+--- findlib-1.5.5.orig/configure
++++ findlib-1.5.5/configure
+@@ -515,7 +515,7 @@ fi
+
+ # Generate the META files now.
+
+-l="$ldbm dynlink graphics num num-top str threads unix stdlib bigarray $llabltk $lcamlp4 $lobuild $lcomplibs $lbytes"
++l="$ldbm dynlink graphics num num-top str threads unix stdlib bigarray $lcomplibs $lbytes"
+
+ for dir in site-lib-src/*; do
+ # We do not really know if $dir is a directory.
diff --git a/dev-ml/findlib/findlib-1.6.1-r1.ebuild b/dev-ml/findlib/findlib-1.6.1-r1.ebuild
new file mode 100644
index 000000000000..4d060131604f
--- /dev/null
+++ b/dev-ml/findlib/findlib-1.6.1-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib eutils
+
+DESCRIPTION="OCaml tool to find/use non-standard packages"
+HOMEPAGE="http://projects.camlcity.org/projects/findlib.html"
+SRC_URI="http://download.camlcity.org/download/${P}.tar.gz"
+IUSE="doc +ocamlopt tk"
+
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND=">=dev-lang/ocaml-4.02.1:=[ocamlopt?]
+ tk? ( dev-ml/labltk:= )"
+RDEPEND="${DEPEND}"
+
+ocamlfind_destdir="${EPREFIX}/usr/$(get_libdir)/ocaml"
+stublibs="${ocamlfind_destdir}/stublibs"
+
+src_prepare() {
+ epatch "${FILESDIR}/externalmeta2.patch" \
+ "${FILESDIR}/quoting.patch"
+}
+
+src_configure() {
+ local myconf
+ use tk && myconf="-with-toolbox"
+ ./configure -bindir "${EPREFIX}"/usr/bin -mandir "${EPREFIX}"/usr/share/man \
+ -sitelib ${ocamlfind_destdir} \
+ -config ${ocamlfind_destdir}/findlib/findlib.conf \
+ -no-custom \
+ ${myconf} || die "configure failed"
+}
+
+src_compile() {
+ emake -j1 all
+ if use ocamlopt; then
+ emake -j1 opt # optimized code
+ fi
+}
+
+src_install() {
+ emake prefix="${D}" install
+
+ dodir "${stublibs#${EPREFIX}}"
+
+ cd "${S}/doc"
+ dodoc QUICKSTART README DOCINFO
+ use doc && dohtml -r ref-html guide-html
+}
+
+check_stublibs() {
+ local ocaml_stdlib=`ocamlc -where`
+ local ldconf="${ocaml_stdlib}/ld.conf"
+
+ if [ ! -e ${ldconf} ]
+ then
+ echo "${ocaml_stdlib}" > ${ldconf}
+ echo "${ocaml_stdlib}/stublibs" >> ${ldconf}
+ fi
+
+ if [ -z `grep -e ${stublibs} ${ldconf}` ]
+ then
+ echo ${stublibs} >> ${ldconf}
+ fi
+}
+
+pkg_postinst() {
+ check_stublibs
+}