summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2019-11-29 10:54:05 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2019-11-29 10:57:18 +0100
commitb4969d13c56e7d24d75cad721c302b371160fc00 (patch)
tree0680615941340461460a26c974540e66ebf0da69
parentnet-misc/pyhoca-cli: drop old (diff)
downloadgentoo-b4969d13c56e7d24d75cad721c302b371160fc00.tar.gz
gentoo-b4969d13c56e7d24d75cad721c302b371160fc00.tar.bz2
gentoo-b4969d13c56e7d24d75cad721c302b371160fc00.zip
net-misc/pyhoca-cli: 0.6.1.1 bump
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
-rw-r--r--net-misc/pyhoca-cli/Manifest1
-rw-r--r--net-misc/pyhoca-cli/pyhoca-cli-0.6.1.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/net-misc/pyhoca-cli/Manifest b/net-misc/pyhoca-cli/Manifest
index a2309a35d605..a53deae0552e 100644
--- a/net-misc/pyhoca-cli/Manifest
+++ b/net-misc/pyhoca-cli/Manifest
@@ -1 +1,2 @@
DIST pyhoca-cli-0.6.0.1.tar.gz 40816 BLAKE2B 719ca6f277cfd2ecd2100e1b34e1c0d4d7e6849eb0b8f39d2a1628878b4da1bdcc1db622144d815347c33e0148d7fd6303caa661f146e18422169d7ae455c993 SHA512 65ced3bcb6e8fc15d22b0abc760a981af66b10325278613a9276de16c1e73d3b8d325b57aed9d4faf43a6d9eb8167045716c2974d4f6563c7a51df8ee66a69eb
+DIST pyhoca-cli-0.6.1.1.tar.gz 41893 BLAKE2B 39f695224c64dacf0f2efa449ff3e235f22571647e77dd58ed031a0899991337af8deff5808293b4f1e1932a47dbd7af63ab6b86b1c5373122f4678eefec168a SHA512 b83e584f314df936d09cda25b253bbd5f37aa7f57db084424b2696070963a99776284c827f602321329bd066c6f483f32cd3dd0aa961eea7c79aa217949966c7
diff --git a/net-misc/pyhoca-cli/pyhoca-cli-0.6.1.1.ebuild b/net-misc/pyhoca-cli/pyhoca-cli-0.6.1.1.ebuild
new file mode 100644
index 000000000000..30c368003023
--- /dev/null
+++ b/net-misc/pyhoca-cli/pyhoca-cli-0.6.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="X2Go command line client"
+HOMEPAGE="http://www.x2go.org"
+SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setproctitle[${PYTHON_USEDEP}]
+ >=net-misc/python-x2go-0.6.1.1[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_install() {
+ distutils-r1_python_install
+ python_doscript ${PN}
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman man/man1/*
+ find "${ED}" -name '*.pth' -delete || die
+}