summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2018-09-06 22:36:19 +0100
committerJames Le Cuirot <chewi@gentoo.org>2019-01-11 09:01:39 +0000
commitb4c99f8f901c4f96390c8b75f642a682970f3aa5 (patch)
treeab28b86d175e3ac20737b75cf750863c5e79195d
parentsys-kernel/raspberrypi-sources: add 4.19 LTS branch (diff)
downloadgentoo-b4c99f8f901c4f96390c8b75f642a682970f3aa5.tar.gz
gentoo-b4c99f8f901c4f96390c8b75f642a682970f3aa5.tar.bz2
gentoo-b4c99f8f901c4f96390c8b75f642a682970f3aa5.zip
dev-python/html5-parser: Version bump to 0.4.5, EAPI 7
Fixes cross-compiling by using the correct pkg-config. Signed-off-by: James Le Cuirot <chewi@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.10
-rw-r--r--dev-python/html5-parser/Manifest1
-rw-r--r--dev-python/html5-parser/html5-parser-0.4.5.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/html5-parser/Manifest b/dev-python/html5-parser/Manifest
index 9feb2fbcc430..091d7c86375f 100644
--- a/dev-python/html5-parser/Manifest
+++ b/dev-python/html5-parser/Manifest
@@ -1 +1,2 @@
DIST html5-parser-0.4.4.tar.gz 267787 BLAKE2B 9fcaec9faa906914d43f2b19381fe3095d4cd009bfb534537d2eabb420195276b3690d760c1defc92ad00e4965b3eb34ce4700d54f4f0291dff88026d890c90d SHA512 3aaeb32f360d2c131ecbe11fa1dcd3dfcd62c9ca046fce7dd4ff8127d0e62216f666e83bb20c7809c6adc591e1fb2798e382e78a1cf6129b1f0a09a71377f8d4
+DIST html5-parser-0.4.5.tar.gz 275587 BLAKE2B e26db3b6c55d43e26eb08076c59012814c2dd8739d6cba591e34cf8e304aa78bdf3440405668875acece2c21425f26ed9a0edbc5bb1da55da09c17eb52fa74aa SHA512 3c0421dd228ba5f3544f188fde5391d6be0fe92b879cf1e7697b5e5612a9e5bf08863bcb76f4297a59bfbfc69010a95f5d97fff78a7e6d26c889e173b07e4ae5
diff --git a/dev-python/html5-parser/html5-parser-0.4.5.ebuild b/dev-python/html5-parser/html5-parser-0.4.5.ebuild
new file mode 100644
index 000000000000..7ca21bb61c3c
--- /dev/null
+++ b/dev-python/html5-parser/html5-parser-0.4.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="Fast C based HTML 5 parsing for python"
+HOMEPAGE="https://github.com/kovidgoyal/html5-parser/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="dev-libs/libxml2:="
+RDEPEND="${DEPEND}
+ dev-python/chardet[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.8.0[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ # Soup is not used when lxml is available.
+ rm test/soup.py || die
+ distutils-r1_src_prepare
+}
+
+src_configure() {
+ export PKGCONFIG_EXE=$(tc-getPKG_CONFIG)
+}
+
+python_test() {
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}