summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-12-23 11:33:25 +0100
committerPacho Ramos <pacho@gentoo.org>2015-12-23 11:58:47 +0100
commitb50cf0fddc2d9187749e1fb5cf4a1852b26203df (patch)
treecbe145f7b4ccd844b9abe1dc13efb5822d1f48e4
parentdev-cpp/libgnomemm: Fix building with latest glibmm/libsigc++ (diff)
downloadgentoo-b50cf0fddc2d9187749e1fb5cf4a1852b26203df.tar.gz
gentoo-b50cf0fddc2d9187749e1fb5cf4a1852b26203df.tar.bz2
gentoo-b50cf0fddc2d9187749e1fb5cf4a1852b26203df.zip
dev-cpp/libgnomeuimm: Fix building with latest glibmm/libsigc++
Package-Manager: portage-2.2.26
-rw-r--r--dev-cpp/libgnomeuimm/libgnomeuimm-2.28.0-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-cpp/libgnomeuimm/libgnomeuimm-2.28.0-r2.ebuild b/dev-cpp/libgnomeuimm/libgnomeuimm-2.28.0-r2.ebuild
new file mode 100644
index 000000000000..57c819423e08
--- /dev/null
+++ b/dev-cpp/libgnomeuimm/libgnomeuimm-2.28.0-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GNOME_TARBALL_SUFFIX="bz2"
+GCONF_DEBUG="no"
+
+inherit flag-o-matic gnome2
+
+DESCRIPTION="C++ bindings for libgnomeui"
+HOMEPAGE="http://www.gtkmm.org"
+
+LICENSE="LGPL-2.1"
+SLOT="2.6"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="
+ >=gnome-base/libgnomeui-2.7.1
+ dev-cpp/glibmm
+ >=dev-cpp/libgnomemm-2.16.0
+ >=dev-cpp/libgnomecanvasmm-2.6
+ >=dev-cpp/gconfmm-2.6
+ >=dev-cpp/libglademm-2.4
+ >=dev-cpp/gnome-vfsmm-2.16
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ append-cxxflags -std=c++11
+ gnome2_src_prepare
+}