summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2020-06-21 09:54:42 +0200
committerPatrice Clement <monsieurp@gentoo.org>2020-06-21 09:54:53 +0200
commitb5c90ab5aff3349352d3359711760f30b4a7e19c (patch)
tree3e31609d11f2dc6c293995800fe272160a88cb93
parentapp-misc/ondir: honour CFLAGS, LD and LDFLAGS. (diff)
downloadgentoo-b5c90ab5aff3349352d3359711760f30b4a7e19c.tar.gz
gentoo-b5c90ab5aff3349352d3359711760f30b4a7e19c.tar.bz2
gentoo-b5c90ab5aff3349352d3359711760f30b4a7e19c.zip
app-misc/grc: version bump.
add python{3_7,3_8} to PYTHON_COMPAT whilst at it (tested). Closes: https://bugs.gentoo.org/718228 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--app-misc/grc/Manifest1
-rw-r--r--app-misc/grc/grc-1.11.3.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/app-misc/grc/Manifest b/app-misc/grc/Manifest
index 34c8f1ebed7f..9dc3f54dfb2b 100644
--- a/app-misc/grc/Manifest
+++ b/app-misc/grc/Manifest
@@ -1 +1,2 @@
+DIST grc-1.11.3.tar.gz 45205 BLAKE2B 852f58145fe11ceab3e6222b61c18cdb18a09f0666f28df4b8b8a8bc42a22dd01ae7e2bcf6232a6aa0d1f42ac233148f694a0eafbd995fbd5d147e06480f7abf SHA512 abc756a21e039c136bbf9be1ef7c1890aa2415ac21e87fb7377c90ced1def2dcaf9ce5cce22edeac68db20f6d6ccea31a2ec57044a37ba200ff79273bf11d8cf
DIST grc-1.11.tar.gz 43224 BLAKE2B 40fe050f1198dadd039ad91fedf279ad5e913e803a669335ee21158f7f9702f3fd65ee5876595b9a4ce46da2f7f3c2cc589bf7ea3e10d84c37b5f20677ed626b SHA512 abaa18aeebf9858369b639975ae6c9a33f3111beb783b4e86463ace70de1d660efc6c17b05020862c3b2f467310f0974443f96d4f91cd322a90731c4be49206c
diff --git a/app-misc/grc/grc-1.11.3.ebuild b/app-misc/grc/grc-1.11.3.ebuild
new file mode 100644
index 000000000000..3c1f47c29702
--- /dev/null
+++ b/app-misc/grc/grc-1.11.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit eutils python-r1
+
+DESCRIPTION="Generic Colouriser beautifies your logfiles or output of commands"
+HOMEPAGE="http://kassiopeia.juls.savba.sk/~garabik/software/grc.html"
+SRC_URI="https://github.com/garabik/grc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+DOCS=( README.markdown INSTALL TODO debian/changelog CREDITS Regexp.txt )
+
+src_prepare() {
+ sed \
+ -e 's:#! :#!:g' \
+ -e 's:3$::g' \
+ -i grc grcat || die
+ default
+}
+
+src_install() {
+ python_foreach_impl python_doscript grc grcat
+
+ einstalldocs
+
+ insinto /usr/share/grc
+ doins \
+ contrib/mrsmith/conf.* \
+ colourfiles/conf.* \
+ grc.bashrc \
+ grc.fish \
+ grc.zsh
+
+ insinto /etc
+ doins grc.conf
+ doman *.1
+}
+
+pkg_postinst() {
+ elog
+ elog "Shell specific configurations can be found in ${ROOT}usr/share/grc"
+ elog "Be sure to symlink one to use grc globally:"
+ elog
+ elog " ln -s ${ROOT}usr/share/grc.SHELL ${ROOT}etc/profile.d/grc.sh"
+ elog
+ elog "Replace 'SHELL' in the above command with one of: bashrc, fish, zsh."
+ elog "Afterwards, use '. ${ROOT}etc/profile' to activate grc in existing"
+ elog "shell sessions."
+ elog
+}