summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2016-06-04 16:24:25 +0800
committerJason Zaman <perfinion@gentoo.org>2016-06-04 16:48:56 +0800
commitb65c47d23d4d567a767bedb6a30eb59a349dc6f2 (patch)
tree70303c48c41f9f74fc864da6ece7651a91f08625
parentdev-python/ipython: Version bump to 4.2.0 (diff)
downloadgentoo-b65c47d23d4d567a767bedb6a30eb59a349dc6f2.tar.gz
gentoo-b65c47d23d4d567a767bedb6a30eb59a349dc6f2.tar.bz2
gentoo-b65c47d23d4d567a767bedb6a30eb59a349dc6f2.zip
sec-policy/selinux-base-policy: Add systemd useflag and module
Package-Manager: portage-2.2.28
-rw-r--r--sec-policy/selinux-base-policy/selinux-base-policy-9999.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/sec-policy/selinux-base-policy/selinux-base-policy-9999.ebuild b/sec-policy/selinux-base-policy/selinux-base-policy-9999.ebuild
index 21b98bd9ba70..062dec634f2c 100644
--- a/sec-policy/selinux-base-policy/selinux-base-policy-9999.ebuild
+++ b/sec-policy/selinux-base-policy/selinux-base-policy-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
@@ -20,9 +20,9 @@ fi
HOMEPAGE="https://www.gentoo.org/proj/en/hardened/selinux/"
DESCRIPTION="SELinux policy for core modules"
-IUSE="+unconfined"
+IUSE="systemd +unconfined"
-RDEPEND="=sec-policy/selinux-base-${PVR}"
+RDEPEND="=sec-policy/selinux-base-${PVR}[systemd?]"
PDEPEND="unconfined? ( sec-policy/selinux-unconfined )"
DEPEND=""
@@ -35,6 +35,12 @@ S="${WORKDIR}/"
# itself), when reworked reinclude it. Only postinstall (where -b base.pp is
# added) needs to remain then.
+pkg_setup() {
+ if use systemd; then
+ MODS="${MODS} systemd"
+ fi
+}
+
pkg_pretend() {
for i in ${POLICY_TYPES}; do
if [[ "${i}" == "targeted" ]] && ! use unconfined; then