summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2019-10-28 21:27:51 +0000
committerJames Le Cuirot <chewi@gentoo.org>2019-10-28 21:38:30 +0000
commitb696a4232de0de1fad8e77c642e2b506e2433ff4 (patch)
treeb3834a99fac0f4ae6fba0d5c5e958acef9fd18d8
parentdev-db/kyotocabinet: QA fix in SRC_URI (diff)
downloadgentoo-b696a4232de0de1fad8e77c642e2b506e2433ff4.tar.gz
gentoo-b696a4232de0de1fad8e77c642e2b506e2433ff4.tar.bz2
gentoo-b696a4232de0de1fad8e77c642e2b506e2433ff4.zip
games-emulation/zsnes: Drop old 1.51-r6
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--games-emulation/zsnes/files/zsnes-1.51-stack-align.patch15
-rw-r--r--games-emulation/zsnes/zsnes-1.51-r6.ebuild117
2 files changed, 0 insertions, 132 deletions
diff --git a/games-emulation/zsnes/files/zsnes-1.51-stack-align.patch b/games-emulation/zsnes/files/zsnes-1.51-stack-align.patch
deleted file mode 100644
index 5dcbf3ad9ebc..000000000000
--- a/games-emulation/zsnes/files/zsnes-1.51-stack-align.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/linux/sdllink.c.old
-+++ src/linux/sdllink.c
-@@ -773,11 +773,11 @@ BOOL InitInput()
- {
- InitJoystickInput();
- return TRUE;
- }
-
--int startgame()
-+int __attribute__((force_align_arg_pointer)) startgame()
- {
- static bool ranonce = false;
- int status;
-
- if (!ranonce)
diff --git a/games-emulation/zsnes/zsnes-1.51-r6.ebuild b/games-emulation/zsnes/zsnes-1.51-r6.ebuild
deleted file mode 100644
index 288fa85dff10..000000000000
--- a/games-emulation/zsnes/zsnes-1.51-r6.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit autotools desktop flag-o-matic toolchain-funcs pax-utils
-
-DESCRIPTION="SNES (Super Nintendo) emulator that uses x86 assembly"
-HOMEPAGE="http://www.zsnes.com/ http://ipherswipsite.com/zsnes/"
-SRC_URI="mirror://sourceforge/zsnes/${PN}${PV//./}src.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="ao custom-cflags +debug opengl pax_kernel png"
-
-RDEPEND="
- media-libs/libsdl[sound,video,abi_x86_32(-)]
- >=sys-libs/zlib-1.2.3-r1[abi_x86_32(-)]
- ao? ( media-libs/libao[abi_x86_32(-)] )
- debug? ( sys-libs/ncurses:0=[abi_x86_32(-)] )
- opengl? ( virtual/opengl[abi_x86_32(-)] )
- png? ( media-libs/libpng:0=[abi_x86_32(-)] )
-"
-DEPEND="${RDEPEND}
- dev-lang/nasm
- debug? ( virtual/pkgconfig )
-"
-
-S="${WORKDIR}/${PN}_${PV//./_}/src"
-
-src_prepare() {
- default
-
- # Fixing compilation without libpng installed
- # Fix bug #186111
- # Fix bug #214697
- # Fix bug #170108
- # Fix bug #260247
- # Fix compability with libpng15 wrt #378735
- # Fix buffer overwrite #257963
- # Fix gcc47 compile #419635
- # Fix stack alignment issue #503138
- eapply \
- "${FILESDIR}"/${P}-libpng.patch \
- "${FILESDIR}"/${P}-archopt-july-23-update.patch \
- "${FILESDIR}"/${P}-gcc43.patch \
- "${FILESDIR}"/${P}-libao-thread.patch \
- "${FILESDIR}"/${P}-depbuild.patch \
- "${FILESDIR}"/${P}-CC-quotes.patch \
- "${FILESDIR}"/${P}-libpng15.patch \
- "${FILESDIR}"/${P}-buffer.patch \
- "${FILESDIR}"/${P}-gcc47.patch \
- "${FILESDIR}"/${P}-stack-align.patch \
- "${FILESDIR}"/${P}-cross-compile.patch \
- "${FILESDIR}"/${P}-arch.patch
-
- # The sdl detection logic uses AC_PROG_PATH instead of
- # AC_PROG_TOOL, so force the var to get set the way we
- # need for things to work correctly.
- tc-is-cross-compiler && export ac_cv_path_SDL_CONFIG=${CHOST}-sdl-config
-
- sed -i -e '67i#define OF(x) x' zip/zunzip.h || die
-
- # Remove hardcoded CFLAGS and LDFLAGS
- sed -i \
- -e '/^CFLAGS=.*local/s:-pipe.*:-Wall -I.":' \
- -e '/^LDFLAGS=.*local/d' \
- -e '/\w*CFLAGS=.*fomit/s:-O3.*$STRIP::' \
- -e '/lncurses/s:-lncurses:`pkg-config ncurses --libs`:' \
- -e '/lcurses/s:-lcurses:`pkg-config ncurses --libs`:' \
- configure.in || die
- sed -i \
- -e 's/configure.in/configure.ac/' \
- Makefile.in || die
- mv configure.in configure.ac || die
- eautoreconf
-}
-
-src_configure() {
- tc-export CC
- export BUILD_CXX=$(tc-getBUILD_CXX)
- export NFLAGS=-O1
- use amd64 && multilib_toolchain_setup x86
- use custom-cflags || strip-flags
-
- append-cppflags -U_FORTIFY_SOURCE #257963
-
- econf \
- $(use_enable ao libao) \
- $(use_enable debug debugger) \
- $(use_enable png libpng) \
- $(use_enable opengl) \
- --disable-debug \
- --disable-cpucheck
-}
-
-src_compile() {
- emake makefile.dep
- emake
-}
-
-src_install() {
- dobin zsnes
- if use pax_kernel; then
- pax-mark m "${D}""${GAMES_BINDIR}"/zsnes || die
- fi
-
- newman linux/zsnes.1 zsnes.6
-
- dodoc \
- ../docs/{readme.1st,authors.txt,srcinfo.txt,stdards.txt,support.txt,thanks.txt,todo.txt,README.LINUX} \
- ../docs/readme.txt/*
- HTML_DOCS="../docs/readme.htm/*" einstalldocs
-
- make_desktop_entry zsnes ZSNES
- newicon icons/48x48x32.png ${PN}.png
-}