summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-09-11 03:17:30 +1200
committerKent Fredric <kentnl@gentoo.org>2020-09-11 03:18:05 +1200
commitb6b10804c82853f5b95b46095ea8a47eceb3c519 (patch)
treef5028cfebe00f5e5739218d3b3b23db3d58f06a8
parentdev-libs/botan: security cleanup (diff)
downloadgentoo-b6b10804c82853f5b95b46095ea8a47eceb3c519.tar.gz
gentoo-b6b10804c82853f5b95b46095ea8a47eceb3c519.tar.bz2
gentoo-b6b10804c82853f5b95b46095ea8a47eceb3c519.zip
dev-perl/Filesys-Statvfs: -r bump for CFLAGS love & fixes
- Fix DESCRIPTION - Remove unused/empty variable assignments - Ensure CFLAGS passed to make/compiler Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
-rw-r--r--dev-perl/Filesys-Statvfs/Filesys-Statvfs-0.820.0-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-perl/Filesys-Statvfs/Filesys-Statvfs-0.820.0-r1.ebuild b/dev-perl/Filesys-Statvfs/Filesys-Statvfs-0.820.0-r1.ebuild
new file mode 100644
index 000000000000..e91241c15f58
--- /dev/null
+++ b/dev-perl/Filesys-Statvfs/Filesys-Statvfs-0.820.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=IGUTHRIE
+DIST_VERSION=0.82
+inherit perl-module
+
+DESCRIPTION="Perl extension for statvfs() and fstatvfs()"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="virtual/perl-ExtUtils-MakeMaker"
+
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}