summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-26 14:42:23 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-26 14:42:23 +0100
commitb786a2a4ae443335994858df991fb2c42bdba00e (patch)
tree4450736055f3363c83d102228e98181efb6c71f6
parentdev-python/basemap: Remove redundant versions (diff)
downloadgentoo-b786a2a4ae443335994858df991fb2c42bdba00e.tar.gz
gentoo-b786a2a4ae443335994858df991fb2c42bdba00e.tar.bz2
gentoo-b786a2a4ae443335994858df991fb2c42bdba00e.zip
dev-python/beautifulsoup: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/beautifulsoup/Manifest2
-rw-r--r--dev-python/beautifulsoup/beautifulsoup-4.5.1.ebuild47
-rw-r--r--dev-python/beautifulsoup/beautifulsoup-4.6.3.ebuild46
3 files changed, 0 insertions, 95 deletions
diff --git a/dev-python/beautifulsoup/Manifest b/dev-python/beautifulsoup/Manifest
index 5778b158fe08..66c4fd139bf3 100644
--- a/dev-python/beautifulsoup/Manifest
+++ b/dev-python/beautifulsoup/Manifest
@@ -1,5 +1,3 @@
DIST BeautifulSoup-3.2.1.tar.gz 31224 BLAKE2B 9361ce6d048d0443c3257d10ec2734c24202af8eb850a59a4344e6992856f849d92dd509f102c27cdf9634bbc235e5f96e304993e6d4813d275d66bd3791b451 SHA512 365b7b045a2069cf437877543577bc0aa99256a6dc4c9743670b46bfceab5494a06628012d6eccecfe99c25d5c9e0c65814964b47026f15ba1a538444cfb7789
-DIST beautifulsoup4-4.5.1.tar.gz 158039 BLAKE2B 5eb99c7efdb13c359385c7c7f3280332ca28cc4b5ff80b90c326d80ef55acef8e98d86691a7b1df420bf68bc65e96ad7d559b461a03f44e494fb4b7789753601 SHA512 d560d7f743507084ec546708d29bb3764512f5b2c380004280dde813350bf48d1697fddce3bd3f95186407bf5142941d7adc7d0de8e7962eb5ca1278dbc7e93f
-DIST beautifulsoup4-4.6.3.tar.gz 167469 BLAKE2B 0bc8f729298a2fd1e8f3cc8a7635587217f9a2e6e2c71709e99c40eedf1ebb4d76cd0d17ec36b99f3ee047193e4d44e31b8d2aa9864c43ce5db380fbdc083f76 SHA512 0cacae77843326ebee87d108b6706a7ca6943684bcccc62554d2ae5d77dfd181c97435ceca9d3e2e51962b024bbe52bc08d7f0dc516311aa87b3a1f87fb4ae23
DIST beautifulsoup4-4.8.1.tar.gz 159164 BLAKE2B 00121e9b30f700ade0bb2ec8f637b4173ecb4c187b8f9a77bcc4e6b333fced85a699c8d9efa5b757ab02f54c2b05740702c13625ff427730ccc1f6a97f43fa48 SHA512 7abc5e84cb8da5428dafc6b473418d0cc72b518cb1a73d4ae58b8dad3ec985e5778629dc1d7c8374dfb223be981983c745a1dbb55a98078b4cfe7ba5ce25539b
DIST beautifulsoup4-4.8.2.tar.gz 298650 BLAKE2B 6826abf793efa63be89d844bc25bdb105413196bfab21c18f3816fd59a7a771459bf2c7ee209b75b0c88dfa14da8f4625c948889acfb48502e2260ccca229675 SHA512 aab90eb22614e9a2fb47792389a951b3ad7faf9791e15984a6c27a38be6f3d0ccbf3a9753d9afb5c70105097ac1a9c5f9e07206e12c6d4cb7a7f6d4e90ec18c2
diff --git a/dev-python/beautifulsoup/beautifulsoup-4.5.1.ebuild b/dev-python/beautifulsoup/beautifulsoup-4.5.1.ebuild
deleted file mode 100644
index 5d1c9763c154..000000000000
--- a/dev-python/beautifulsoup/beautifulsoup-4.5.1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
-
-inherit distutils-r1
-
-MY_PN=${PN}4
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Provides pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
-HOMEPAGE="https://bugs.launchpad.net/beautifulsoup/
- https://pypi.org/project/beautifulsoup4/"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="4"
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-# html5lib is optional however hard coding since its use is actively discouraged in the devmanual
-RDEPEND="
- $(python_gen_cond_dep 'dev-python/html5lib[${PYTHON_USEDEP}]' python2_7 pypy)
- $(python_gen_cond_dep 'dev-python/lxml[${PYTHON_USEDEP}]' python2_7 'python3*')"
-DEPEND="
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
- "
-
-S=${WORKDIR}/${MY_P}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- nosetests --verbose -w "${BUILD_DIR}"/lib || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/beautifulsoup/beautifulsoup-4.6.3.ebuild b/dev-python/beautifulsoup/beautifulsoup-4.6.3.ebuild
deleted file mode 100644
index 23c46d032439..000000000000
--- a/dev-python/beautifulsoup/beautifulsoup-4.6.3.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-
-inherit distutils-r1
-
-MY_PN=${PN}4
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
-HOMEPAGE="https://www.crummy.com/software/BeautifulSoup/bs4/"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="4"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-# html5lib is optional however hard coding since its use is actively discouraged in the devmanual
-RDEPEND="
- $(python_gen_cond_dep 'dev-python/html5lib[${PYTHON_USEDEP}]' python2_7 pypy)
- $(python_gen_cond_dep 'dev-python/lxml[${PYTHON_USEDEP}]' python2_7 'python3*')"
-DEPEND="
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
- "
-
-S="${WORKDIR}/${MY_P}"
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- nosetests --verbose -w "${BUILD_DIR}"/lib || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/build/html/. )
- distutils-r1_python_install_all
-}