summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-01-09 11:17:45 +1300
committerKent Fredric <kentnl@gentoo.org>2018-01-09 11:42:06 +1300
commitb796dbc2e675a03c565e4274f827f26a7c504f2b (patch)
tree7c14974a84fc7bf2fb51e24c1c3f30b9992cfbfc
parentmedia-tv/plex-media-server: version bump to 1.10.1, removing old versions. (diff)
downloadgentoo-b796dbc2e675a03c565e4274f827f26a7c504f2b.tar.gz
gentoo-b796dbc2e675a03c565e4274f827f26a7c504f2b.tar.bz2
gentoo-b796dbc2e675a03c565e4274f827f26a7c504f2b.zip
dev-perl/SQL-Translator: Bump to version 0.110.230
- EAPI6 - Parallel tests Upstream: - Fix for '.' in @INC - Remove use of List::MoreUtils - Add support for monotonically increasing SQLite autoincrements - Add support for CHECK constraint in SQLite producer - Fix error handling for recent Test::PostgreSQL - Add support for CHECK constraint in POD producer - Fix quoting in MYSQL DROP TABLE diff producer - Fix Pg grammar parsing of UUID, time, and timetz columns - Add support for USING and WHERE on index in Postgres producer/parser - Improve add_trigger consistency - Add trigger 'scope' attribute to support JSON/YAML/XML producers and XML and SQLite parser - Speedup internal debugging mechanism - Fix parsing of strings with leading whitespace - Fix parsing of MySQL column comments - Fix Multiline comments in YAML, JSON & Postgreqsl producers - Fix identifier quoting in Postgresql diff producer - Fix incorrect type conversion from BigInt AutoIncrement to bigserial - Fix missing semicolons between PostGIS statements - Fix string/identifier quoting in PostGIS statements - Fix test failures and test dependence on exact serialization Package-Manager: Portage-2.3.18, Repoman-2.3.6
-rw-r--r--dev-perl/SQL-Translator/Manifest1
-rw-r--r--dev-perl/SQL-Translator/SQL-Translator-0.110.230.ebuild41
-rw-r--r--dev-perl/SQL-Translator/metadata.xml3
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-perl/SQL-Translator/Manifest b/dev-perl/SQL-Translator/Manifest
index 9e2ba7aabd2c..9683a70d25db 100644
--- a/dev-perl/SQL-Translator/Manifest
+++ b/dev-perl/SQL-Translator/Manifest
@@ -1 +1,2 @@
DIST SQL-Translator-0.11021.tar.gz 438222 BLAKE2B e8292838b23ff7523227b63bf2c85424596f35ae4138b1526e5463cf3727140fe91400a1b897a268597791c575204e159237f8f067c2aa98ce7077e2e5277efb SHA512 d8bd12932d522ff6feb6821e7fbe95e804861c1d07035185b05e5a151f4fd4ddec233fb43637700ba32aa3e252df5590281db9d38b553a791e9d4bf15f68d5f7
+DIST SQL-Translator-0.11023.tar.gz 436852 BLAKE2B 62fe969cfe93bb0cecb59d1690a0a13b54b5e46db5d20479da2a37c8b459a96021081f7bcbac998c40baf459306cea27bcadb9dcd7a0e99a0686b1134c7a4af4 SHA512 95ae982c504b464f988b8bc04f8e733053978bbbeb532cc86ffb90485823403d403ee86ff562b591b1b82bf99bcfa357385eb6690e5c06c968dbde5653afb4dc
diff --git a/dev-perl/SQL-Translator/SQL-Translator-0.110.230.ebuild b/dev-perl/SQL-Translator/SQL-Translator-0.110.230.ebuild
new file mode 100644
index 000000000000..b751d90e08be
--- /dev/null
+++ b/dev-perl/SQL-Translator/SQL-Translator-0.110.230.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=ILMARI
+DIST_VERSION=0.11023
+inherit perl-module
+
+DESCRIPTION="Manipulate structured data definitions (SQL and more)"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-aix ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/Carp-Clan
+ >=dev-perl/DBI-1.540.0
+ virtual/perl-Digest-SHA
+ >=dev-perl/File-ShareDir-1.0.0
+ >=dev-perl/Moo-1.0.3
+ >=dev-perl/Package-Variant-1.1.1
+ >=dev-perl/Parse-RecDescent-1.967.9
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Sub-Quote
+ >=dev-perl/Try-Tiny-0.40.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.590.0
+ >=dev-perl/JSON-2
+ >=dev-perl/XML-Writer-0.500.0
+ >=dev-perl/YAML-0.660.0
+ test? (
+ dev-perl/HTML-Parser
+ >=dev-perl/Spreadsheet-ParseExcel-0.410.0
+ >=dev-perl/Template-Toolkit-2.200.0
+ dev-perl/Test-Exception
+ >=dev-perl/Test-Differences-0.310.0
+ >=virtual/perl-Test-Simple-0.880.0
+ >=dev-perl/XML-LibXML-1.690.0
+ )
+"
diff --git a/dev-perl/SQL-Translator/metadata.xml b/dev-perl/SQL-Translator/metadata.xml
index db3b61bd3dca..0a0176a81d1a 100644
--- a/dev-perl/SQL-Translator/metadata.xml
+++ b/dev-perl/SQL-Translator/metadata.xml
@@ -13,6 +13,7 @@
<remote-id type="cpan-module">SQL::Translator::Filter::DefaultExtra</remote-id>
<remote-id type="cpan-module">SQL::Translator::Filter::Globals</remote-id>
<remote-id type="cpan-module">SQL::Translator::Filter::Names</remote-id>
+ <remote-id type="cpan-module">SQL::Translator::Generator::DDL::MySQL</remote-id>
<remote-id type="cpan-module">SQL::Translator::Generator::DDL::PostgreSQL</remote-id>
<remote-id type="cpan-module">SQL::Translator::Generator::DDL::SQLServer</remote-id>
<remote-id type="cpan-module">SQL::Translator::Generator::DDL::SQLite</remote-id>
@@ -31,6 +32,7 @@
<remote-id type="cpan-module">SQL::Translator::Parser::DBI::SQLite</remote-id>
<remote-id type="cpan-module">SQL::Translator::Parser::DBI::Sybase</remote-id>
<remote-id type="cpan-module">SQL::Translator::Parser::Excel</remote-id>
+ <remote-id type="cpan-module">SQL::Translator::Parser::JSON</remote-id>
<remote-id type="cpan-module">SQL::Translator::Parser::MySQL</remote-id>
<remote-id type="cpan-module">SQL::Translator::Parser::Oracle</remote-id>
<remote-id type="cpan-module">SQL::Translator::Parser::PostgreSQL</remote-id>
@@ -50,6 +52,7 @@
<remote-id type="cpan-module">SQL::Translator::Producer::Dumper</remote-id>
<remote-id type="cpan-module">SQL::Translator::Producer::GraphViz</remote-id>
<remote-id type="cpan-module">SQL::Translator::Producer::HTML</remote-id>
+ <remote-id type="cpan-module">SQL::Translator::Producer::JSON</remote-id>
<remote-id type="cpan-module">SQL::Translator::Producer::Latex</remote-id>
<remote-id type="cpan-module">SQL::Translator::Producer::MySQL</remote-id>
<remote-id type="cpan-module">SQL::Translator::Producer::Oracle</remote-id>