summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-04-12 20:40:21 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-04-12 20:51:00 +0200
commitb8cc095e1f60a7a0b498793a6a374f4b226ebd84 (patch)
tree802aacd1d98342ac315701522c54ff4fa50f3127
parentdev-ros/rospack: Remove old (diff)
downloadgentoo-b8cc095e1f60a7a0b498793a6a374f4b226ebd84.tar.gz
gentoo-b8cc095e1f60a7a0b498793a6a374f4b226ebd84.tar.bz2
gentoo-b8cc095e1f60a7a0b498793a6a374f4b226ebd84.zip
dev-ros/rospack: bump to 2.5.0
Package-Manager: Portage-2.3.28, Repoman-2.3.9
-rw-r--r--dev-ros/rospack/Manifest1
-rw-r--r--dev-ros/rospack/files/boost165.patch231
-rw-r--r--dev-ros/rospack/rospack-2.5.0.ebuild31
-rw-r--r--dev-ros/rospack/rospack-9999.ebuild4
4 files changed, 34 insertions, 233 deletions
diff --git a/dev-ros/rospack/Manifest b/dev-ros/rospack/Manifest
index eb9b17da7c24..7c5ab380bb95 100644
--- a/dev-ros/rospack/Manifest
+++ b/dev-ros/rospack/Manifest
@@ -1 +1,2 @@
DIST rospack-2.4.3.tar.gz 72327 BLAKE2B b154ce307ed95403382030c0fe14bd6296174289333fea83356a4f77add0fe2a1e48c8e2b6ee037def2e823f61a7b6df4ea62fd9a6f84433f12247003823f86f SHA512 4396ef24d0bd826235d7ac0da8a0b502557ecc0086eadcda96d44779ed5d8134e9a53cd861ee135a4b1da53074bdcf906dc4cb6ea0c36798326c17788ee1e2be
+DIST rospack-2.5.0.tar.gz 72447 BLAKE2B 820e893544b38464bfc63b516697fac9e5875bfffb0922aa0da4b572af5e47a0f4a63134786131fd0ae97751916748b0a1e6af6ca29897ef72759b601bffb551 SHA512 8c9ed4566aa1456b2dd3c4249f7023121d21ee99427d0ef78a7237fbe418f333859091b66870572d5a80995ebda9d5208643ae92213827af40c63b49be4a2560
diff --git a/dev-ros/rospack/files/boost165.patch b/dev-ros/rospack/files/boost165.patch
deleted file mode 100644
index fda1c6668107..000000000000
--- a/dev-ros/rospack/files/boost165.patch
+++ /dev/null
@@ -1,231 +0,0 @@
-commit 6fcee1b0d2b1c225c39a5820981166b99f0d8750
-Author: Tim Rakowski <tim.rakowski@googlemail.com>
-Date: Mon Sep 4 21:41:11 2017 +0200
-
- Replaced references to deprecated Boost.TR1
-
- boost/tr1 includes where removed with boost 1.65
-
-diff --git a/include/rospack/rospack.h b/include/rospack/rospack.h
-index 4389187..bb7bc2e 100644
---- a/include/rospack/rospack.h
-+++ b/include/rospack/rospack.h
-@@ -105,8 +105,8 @@ and Rosstack.
- #ifndef ROSPACK_ROSPACK_H
- #define ROSPACK_ROSPACK_H
-
--#include <boost/tr1/unordered_set.hpp>
--#include <boost/tr1/unordered_map.hpp>
-+#include <boost/unordered_set.hpp>
-+#include <boost/unordered_map.hpp>
- #include <list>
- #include <map>
- #include <set>
-@@ -148,8 +148,8 @@ class ROSPACK_DECL Rosstackage
- std::string tag_;
- bool quiet_;
- std::vector<std::string> search_paths_;
-- std::tr1::unordered_map<std::string, std::vector<std::string> > dups_;
-- std::tr1::unordered_map<std::string, Stackage*> stackages_;
-+ boost::unordered_map<std::string, std::vector<std::string> > dups_;
-+ boost::unordered_map<std::string, Stackage*> stackages_;
- Stackage* findWithRecrawl(const std::string& name);
- void log(const std::string& level, const std::string& msg, bool append_errno);
- void clearStackages();
-@@ -159,7 +159,7 @@ class ROSPACK_DECL Rosstackage
- int depth,
- bool collect_profile_data,
- std::vector<DirectoryCrawlRecord*>& profile_data,
-- std::tr1::unordered_set<std::string>& profile_hash);
-+ boost::unordered_set<std::string>& profile_hash);
- bool isStackage(const std::string& path);
- void loadManifest(Stackage* stackage);
- void computeDeps(Stackage* stackage, bool ignore_errors=false, bool ignore_missing=false);
-@@ -171,7 +171,7 @@ class ROSPACK_DECL Rosstackage
- bool no_recursion_on_wet=false);
- void gatherDepsFull(Stackage* stackage, bool direct,
- traversal_order_t order, int depth,
-- std::tr1::unordered_set<Stackage*>& deps_hash,
-+ boost::unordered_set<Stackage*>& deps_hash,
- std::vector<Stackage*>& deps,
- bool get_indented_deps,
- std::vector<std::string>& indented_deps,
-diff --git a/src/rospack.cpp b/src/rospack.cpp
-index 6b88a36..a3e08a3 100644
---- a/src/rospack.cpp
-+++ b/src/rospack.cpp
-@@ -259,7 +259,7 @@ Rosstackage::~Rosstackage()
-
- void Rosstackage::clearStackages()
- {
-- for(std::tr1::unordered_map<std::string, Stackage*>::const_iterator it = stackages_.begin();
-+ for(boost::unordered_map<std::string, Stackage*>::const_iterator it = stackages_.begin();
- it != stackages_.end();
- ++it)
- {
-@@ -382,7 +382,7 @@ Rosstackage::crawl(std::vector<std::string> search_path,
- search_paths_ = search_path;
-
- std::vector<DirectoryCrawlRecord*> dummy;
-- std::tr1::unordered_set<std::string> dummy2;
-+ boost::unordered_set<std::string> dummy2;
- for(std::vector<std::string>::const_iterator p = search_paths_.begin();
- p != search_paths_.end();
- ++p)
-@@ -447,7 +447,7 @@ Rosstackage::contents(const std::string& name,
- std::set<std::string>& packages)
- {
- Rospack rp2;
-- std::tr1::unordered_map<std::string, Stackage*>::const_iterator it = stackages_.find(name);
-+ boost::unordered_map<std::string, Stackage*>::const_iterator it = stackages_.find(name);
- if(it != stackages_.end())
- {
- std::vector<std::string> search_paths;
-@@ -474,7 +474,7 @@ Rosstackage::contains(const std::string& name,
- std::string& path)
- {
- Rospack rp2;
-- for(std::tr1::unordered_map<std::string, Stackage*>::const_iterator it = stackages_.begin();
-+ for(boost::unordered_map<std::string, Stackage*>::const_iterator it = stackages_.begin();
- it != stackages_.end();
- ++it)
- {
-@@ -503,7 +503,7 @@ Rosstackage::contains(const std::string& name,
- void
- Rosstackage::list(std::set<std::pair<std::string, std::string> >& list)
- {
-- for(std::tr1::unordered_map<std::string, Stackage*>::const_iterator it = stackages_.begin();
-+ for(boost::unordered_map<std::string, Stackage*>::const_iterator it = stackages_.begin();
- it != stackages_.end();
- ++it)
- {
-@@ -519,7 +519,7 @@ Rosstackage::listDuplicates(std::vector<std::string>& dups)
- {
- dups.resize(dups_.size());
- int i = 0;
-- for(std::tr1::unordered_map<std::string, std::vector<std::string> >::const_iterator it = dups_.begin();
-+ for(boost::unordered_map<std::string, std::vector<std::string> >::const_iterator it = dups_.begin();
- it != dups_.end();
- ++it)
- {
-@@ -532,7 +532,7 @@ void
- Rosstackage::listDuplicatesWithPaths(std::map<std::string, std::vector<std::string> >& dups)
- {
- dups.clear();
-- for(std::tr1::unordered_map<std::string, std::vector<std::string> >::const_iterator it = dups_.begin();
-+ for(boost::unordered_map<std::string, std::vector<std::string> >::const_iterator it = dups_.begin();
- it != dups_.end();
- ++it)
- {
-@@ -598,7 +598,7 @@ Rosstackage::depsIndent(const std::string& name, bool direct,
- {
- computeDeps(stackage);
- std::vector<Stackage*> deps_vec;
-- std::tr1::unordered_set<Stackage*> deps_hash;
-+ boost::unordered_set<Stackage*> deps_hash;
- std::vector<std::string> indented_deps;
- gatherDepsFull(stackage, direct, POSTORDER, 0, deps_hash, deps_vec, true, indented_deps);
- for(std::vector<std::string>::const_iterator it = indented_deps.begin();
-@@ -1089,7 +1089,7 @@ Rosstackage::plugins(const std::string& name, const std::string& attrib,
- if(!depsOnDetail(name, true, stackages, true))
- return false;
- // Also look in the package itself
-- std::tr1::unordered_map<std::string, Stackage*>::const_iterator it = stackages_.find(name);
-+ boost::unordered_map<std::string, Stackage*>::const_iterator it = stackages_.find(name);
- if(it != stackages_.end())
- {
- // don't warn here; it was done in depsOnDetail()
-@@ -1102,7 +1102,7 @@ Rosstackage::plugins(const std::string& name, const std::string& attrib,
- std::vector<Stackage*> top_deps;
- if(!depsDetail(top, false, top_deps))
- return false;
-- std::tr1::unordered_set<Stackage*> top_deps_set;
-+ boost::unordered_set<Stackage*> top_deps_set;
- for(std::vector<Stackage*>::iterator it = top_deps.begin();
- it != top_deps.end();
- ++it)
-@@ -1292,7 +1292,7 @@ Rosstackage::depsOnDetail(const std::string& name, bool direct,
- }
- try
- {
-- for(std::tr1::unordered_map<std::string, Stackage*>::const_iterator it = stackages_.begin();
-+ for(boost::unordered_map<std::string, Stackage*>::const_iterator it = stackages_.begin();
- it != stackages_.end();
- ++it)
- {
-@@ -1327,7 +1327,7 @@ Rosstackage::profile(const std::vector<std::string>& search_path,
- {
- double start = time_since_epoch();
- std::vector<DirectoryCrawlRecord*> dcrs;
-- std::tr1::unordered_set<std::string> dcrs_hash;
-+ boost::unordered_set<std::string> dcrs_hash;
- for(std::vector<std::string>::const_iterator p = search_path.begin();
- p != search_path.end();
- ++p)
-@@ -1437,7 +1437,7 @@ Rosstackage::crawlDetail(const std::string& path,
- int depth,
- bool collect_profile_data,
- std::vector<DirectoryCrawlRecord*>& profile_data,
-- std::tr1::unordered_set<std::string>& profile_hash)
-+ boost::unordered_set<std::string>& profile_hash)
- {
- if(depth > MAX_CRAWL_DEPTH)
- throw Exception("maximum depth exceeded during crawl");
-@@ -1786,7 +1786,7 @@ Rosstackage::gatherDeps(Stackage* stackage, bool direct,
- std::vector<Stackage*>& deps,
- bool no_recursion_on_wet)
- {
-- std::tr1::unordered_set<Stackage*> deps_hash;
-+ boost::unordered_set<Stackage*> deps_hash;
- std::vector<std::string> indented_deps;
- gatherDepsFull(stackage, direct, order, 0,
- deps_hash, deps, false, indented_deps, no_recursion_on_wet);
-@@ -1795,7 +1795,7 @@ Rosstackage::gatherDeps(Stackage* stackage, bool direct,
- void
- _gatherDepsFull(Stackage* stackage, bool direct,
- traversal_order_t order, int depth,
-- std::tr1::unordered_set<Stackage*>& deps_hash,
-+ boost::unordered_set<Stackage*>& deps_hash,
- std::vector<Stackage*>& deps,
- bool get_indented_deps,
- std::vector<std::string>& indented_deps,
-@@ -1881,7 +1881,7 @@ _gatherDepsFull(Stackage* stackage, bool direct,
- void
- Rosstackage::gatherDepsFull(Stackage* stackage, bool direct,
- traversal_order_t order, int depth,
-- std::tr1::unordered_set<Stackage*>& deps_hash,
-+ boost::unordered_set<Stackage*>& deps_hash,
- std::vector<Stackage*>& deps,
- bool get_indented_deps,
- std::vector<std::string>& indented_deps,
-@@ -2068,7 +2068,7 @@ Rosstackage::writeCache()
- {
- char *rpp = getenv("ROS_PACKAGE_PATH");
- fprintf(cache, "#ROS_PACKAGE_PATH=%s\n", (rpp ? rpp : ""));
-- for(std::tr1::unordered_map<std::string, Stackage*>::const_iterator it = stackages_.begin();
-+ for(boost::unordered_map<std::string, Stackage*>::const_iterator it = stackages_.begin();
- it != stackages_.end();
- ++it)
- fprintf(cache, "%s\n", it->second->path_.c_str());
-diff --git a/src/utils.cpp b/src/utils.cpp
-index 97a557a..f41a00e 100644
---- a/src/utils.cpp
-+++ b/src/utils.cpp
-@@ -28,7 +28,7 @@
- #include <string>
- #include <vector>
- #include <boost/algorithm/string.hpp>
--#include <boost/tr1/unordered_set.hpp>
-+#include <boost/unordered_set.hpp>
-
- #include "utils.h"
-
-@@ -41,7 +41,7 @@ deduplicate_tokens(const std::string& instring,
- std::string& outstring)
- {
- std::vector<std::string> vec;
-- std::tr1::unordered_set<std::string> set;
-+ boost::unordered_set<std::string> set;
- boost::split(vec, instring,
- boost::is_any_of("\t "),
- boost::token_compress_on);
diff --git a/dev-ros/rospack/rospack-2.5.0.ebuild b/dev-ros/rospack/rospack-2.5.0.ebuild
new file mode 100644
index 000000000000..cf86c350e8c7
--- /dev/null
+++ b/dev-ros/rospack/rospack-2.5.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/rospack"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Retrieves information about ROS packages available on the filesystem"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-libs/boost:=
+ >=dev-libs/tinyxml2-5:=
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ >=dev-ros/cmake_modules-0.4.1
+ test? (
+ dev-cpp/gtest
+ dev-python/nose
+ )"
+
+PATCHES=(
+ "${FILESDIR}/gentoo.patch"
+)
diff --git a/dev-ros/rospack/rospack-9999.ebuild b/dev-ros/rospack/rospack-9999.ebuild
index 18b9f633ad3f..cf86c350e8c7 100644
--- a/dev-ros/rospack/rospack-9999.ebuild
+++ b/dev-ros/rospack/rospack-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -17,7 +17,7 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="
dev-libs/boost:=
- dev-libs/tinyxml2:=
+ >=dev-libs/tinyxml2-5:=
${PYTHON_DEPS}"
DEPEND="${RDEPEND}
>=dev-ros/cmake_modules-0.4.1