summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-03-04 01:03:09 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-03-04 11:02:57 +0100
commitb8cf4069ef23fbd881c9fb12b6f56f7fa6fd5f24 (patch)
treeeecefd746848d191ac7b6b67fcdb9c374163abde
parentsys-auth/elogind: Sort build options (diff)
downloadgentoo-b8cf4069ef23fbd881c9fb12b6f56f7fa6fd5f24.tar.gz
gentoo-b8cf4069ef23fbd881c9fb12b6f56f7fa6fd5f24.tar.bz2
gentoo-b8cf4069ef23fbd881c9fb12b6f56f7fa6fd5f24.zip
sys-auth/elogind: docdir to PF
Completely disable meson.build install to docdir - it was not honoring the docdir config switch. Add remaining file to ebuild DOCS manually. Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--sys-auth/elogind/elogind-235.2-r2.ebuild8
-rw-r--r--sys-auth/elogind/files/elogind-235.2-docs.patch19
2 files changed, 24 insertions, 3 deletions
diff --git a/sys-auth/elogind/elogind-235.2-r2.ebuild b/sys-auth/elogind/elogind-235.2-r2.ebuild
index 299badb3a63b..9aebf298ae6b 100644
--- a/sys-auth/elogind/elogind-235.2-r2.ebuild
+++ b/sys-auth/elogind/elogind-235.2-r2.ebuild
@@ -40,7 +40,7 @@ PDEPEND="
"
PATCHES=(
- "${FILESDIR}/${PN}-235.1-docs.patch"
+ "${FILESDIR}/${P}-docs.patch"
"${FILESDIR}/${P}-legacy-cgroupmode.patch"
"${FILESDIR}/${P}-drop-logintest.patch" # bug 645156
)
@@ -69,8 +69,8 @@ src_configure() {
fi
local emesonargs=(
- -Ddocdir="${EPREFIX}/usr/share/doc/${P}"
- -Dhtmldir="${EPREFIX}/usr/share/doc/${P}/html"
+ -Ddocdir="${EPREFIX}/usr/share/doc/${PF}"
+ -Dhtmldir="${EPREFIX}/usr/share/doc/${PF}/html"
-Dpamlibdir=$(getpam_mod_dir)
-Dudevrulesdir="$(get_udevdir)"/rules.d
--libdir="${EPREFIX}"/usr/$(get_libdir)
@@ -96,6 +96,8 @@ src_configure() {
}
src_install() {
+ DOCS+=( src/libelogind/sd-bus/GVARIANT-SERIALIZATION )
+
meson_src_install
newinitd "${FILESDIR}"/${PN}.init ${PN}
diff --git a/sys-auth/elogind/files/elogind-235.2-docs.patch b/sys-auth/elogind/files/elogind-235.2-docs.patch
new file mode 100644
index 000000000000..7fbb4594bdc4
--- /dev/null
+++ b/sys-auth/elogind/files/elogind-235.2-docs.patch
@@ -0,0 +1,19 @@
+--- a/meson.build 2018-01-14 18:59:36.141461154 +0100
++++ b/meson.build 2018-01-14 19:00:46.208461781 +0100
+@@ -2634,16 +2634,5 @@
+ # install_data('modprobe.d/systemd.conf',
+ # install_dir : modprobedir)
+ #endif // 0
+-install_data('README',
+- 'NEWS',
+- 'CODING_STYLE',
+-#if 0 /// UNNEEDED by elogind
+-# 'DISTRO_PORTING',
+-# 'ENVIRONMENT.md',
+-#endif // 0
+- 'LICENSE.GPL2',
+- 'LICENSE.LGPL2.1',
+- 'src/libelogind/sd-bus/GVARIANT-SERIALIZATION',
+- install_dir : docdir)
+
+ meson.add_install_script('sh', '-c', mkdir_p.format(systemdstatedir))