summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-11-06 18:04:31 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-11-06 18:04:31 +0100
commitb902488bdc020caae4082e4370db3333574df2f2 (patch)
treed61446279e9afe07a5529d8e5cb8c938d8eede5d
parentdev-python/hypothesis: bump to 3.6.0, eapi bump, fixed dependencies (diff)
downloadgentoo-b902488bdc020caae4082e4370db3333574df2f2.tar.gz
gentoo-b902488bdc020caae4082e4370db3333574df2f2.tar.bz2
gentoo-b902488bdc020caae4082e4370db3333574df2f2.zip
app-emulation/runv: Initial version
Package-Manager: portage-2.3.2
-rw-r--r--app-emulation/runv/Manifest1
-rw-r--r--app-emulation/runv/metadata.xml15
-rw-r--r--app-emulation/runv/runv-0.7.0.ebuild46
3 files changed, 62 insertions, 0 deletions
diff --git a/app-emulation/runv/Manifest b/app-emulation/runv/Manifest
new file mode 100644
index 000000000000..f3035f9f6434
--- /dev/null
+++ b/app-emulation/runv/Manifest
@@ -0,0 +1 @@
+DIST runv-0.7.0.tar.gz 1143867 SHA256 13107bdcaa2217f870c3b4a18d490984eea1e372947d7e4725aab1166d366697 SHA512 1303d4ca99186d9f5c1db4257acecf1702546a084942cc4c51de8685c6841da45be72c78f32ab38e2addb80dc40fe4d022d0fcae7b7d6b6d62a30f434cea178c WHIRLPOOL a5a7eabeeccab89b5202cad0762f366fd80d6eb52552681124eb636809b28444855561a5849429f78643b14eba576323c7999f2c892caaf5211505e80f72d928
diff --git a/app-emulation/runv/metadata.xml b/app-emulation/runv/metadata.xml
new file mode 100644
index 000000000000..648b9cef5dc9
--- /dev/null
+++ b/app-emulation/runv/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ </maintainer>
+ <use>
+ <flag name="libvirt">Enable support for KVM via libvirt</flag>
+ <flag name="xen">Enable support for the Xen Hypervisor</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">hyperhq/runv</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emulation/runv/runv-0.7.0.ebuild b/app-emulation/runv/runv-0.7.0.ebuild
new file mode 100644
index 000000000000..6b0b9d9b038d
--- /dev/null
+++ b/app-emulation/runv/runv-0.7.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+EGO_PN="github.com/hyperhq/runv"
+
+inherit autotools golang-vcs-snapshot
+
+DESCRIPTION="Hypervisor-based Runtime for OCI"
+HOMEPAGE="https://github.com/hyperhq/runv"
+SRC_URI="https://github.com/hyperhq/runv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libvirt xen"
+
+RDEPEND="libvirt? ( >=app-emulation/libvirt-1.2.2 )
+ xen? ( app-emulation/xen )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ pushd src/github.com/hyperhq/runv/ || die
+ default
+ eautoreconf
+ popd
+}
+
+src_configure() {
+ local myeconfargs=( $(use_with libvirt)
+ $(use_with xen) )
+ pushd src/github.com/hyperhq/runv/ || die
+ econf "${myeconfargs[@]}"
+ popd
+}
+
+src_compile() {
+ GOPATH="${S}:$(get_golibdir_gopath)" emake -C src/github.com/hyperhq/runv/
+}
+
+src_install() {
+ dodoc src/${EGO_PN}/README.md
+ dobin src/${EGO_PN}/runv
+}