summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2016-01-03 00:02:55 +0600
committerAndrey Grozin <grozin@gentoo.org>2016-01-03 00:04:02 +0600
commitba8cc7951401f253480ce8746e2ed0472dacd029 (patch)
tree5778cef59aa7172a7e08b5182c4f2293d367d267
parentdev-perl/DateTime-Format-HTTP: amd64/x86 stable, (ALLARCHES policy) wrt bug #... (diff)
downloadgentoo-ba8cc7951401f253480ce8746e2ed0472dacd029.tar.gz
gentoo-ba8cc7951401f253480ce8746e2ed0472dacd029.tar.bz2
gentoo-ba8cc7951401f253480ce8746e2ed0472dacd029.zip
sci-mathematics/ginac: bump to 1.6.6
Package-Manager: portage-2.2.26
-rw-r--r--sci-mathematics/ginac/Manifest1
-rw-r--r--sci-mathematics/ginac/ginac-1.6.6.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/sci-mathematics/ginac/Manifest b/sci-mathematics/ginac/Manifest
index 3b1485f24a23..bfadcbf8dd5f 100644
--- a/sci-mathematics/ginac/Manifest
+++ b/sci-mathematics/ginac/Manifest
@@ -1,3 +1,4 @@
DIST ginac-1.5.8.tar.bz2 1003965 SHA256 8ce72e70f7539e9a2b32539e13eb651fd688d1423dd90bcf0b9c37b592cfc2dd SHA512 08d9f1b47f369328d5133e4fe286d6bfcd71f30f1c5024bf1310bb88e9fea321da809e5d9f92c08b84f4a7c09af6c342af2f8cb2328857a33671237c6082b167 WHIRLPOOL a30e446a06a595cc4044bea6d3f49c335d8d8e44216ce2cc143d0bfe5702665ffdefb77a76dd07867dae1c1dbae2cbae029433b005849d5109b38238eddde634
DIST ginac-1.6.1.tar.bz2 1048724 SHA256 0658c4a528f37871c5ec24496373fede4e3e59d3223beaf880c75f07a9c2f680 SHA512 5c009e1960d701600f47b306f492b24dccb04cbd4e21d594833db5acf620e230928e1ca471c773918c7d264f057301ddc3a2aa95987d773a9575640ff44f6066 WHIRLPOOL ee95088bd700536ba9246d0145a986b8550d1f2ea479e31b0d8d2bc791f7176e9f2d4d119063626b78156f786f0f44e882429b9a91950c8d130fb8fe7c9d1c57
DIST ginac-1.6.2.tar.bz2 1048764 SHA256 0f34d255024b3fb258e44da84f9e82dfb3dc9bc15f0999b7a18204a730663bde SHA512 6625f9958a1a6167e49d3a3ca442855fa1eab88926565747fda70a8b770db34da0c001f175fa94102ecec1f823d921eba9c98daabd6ed63548bff2b31a3b49cb WHIRLPOOL 40442b8c5820165f4970e95107ce2ac8e22d1c39b60be615d00eefe1f94e061eb6407cf3e8c0bfab15b4b9974168c97ece6cc188c76a8e9484ad9ff065f87962
+DIST ginac-1.6.6.tar.bz2 1028211 SHA256 25ec6d535ee77caf6161843688489cfc319b6c4fda46c5d7878587ee5562ddce SHA512 495ef255dd32e71ee91257a515c0566e56525e0c54c8955c19beaf9e2e55457f7d8171c7e5f6e4f29f555f5d262bbaf4edf4f033166c4904c016987a5029e958 WHIRLPOOL c4efc7286377da939ad8196b898086bb67b63102b23c703d3b5fc462be108fc96883597dea50297ec4a26d5bd19f15af8b01c36782c6e6a1886c284cf19771fc
diff --git a/sci-mathematics/ginac/ginac-1.6.6.ebuild b/sci-mathematics/ginac/ginac-1.6.6.ebuild
new file mode 100644
index 000000000000..45bd7132571e
--- /dev/null
+++ b/sci-mathematics/ginac/ginac-1.6.6.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="C++ library and tools for symbolic calculations"
+SRC_URI="http://www.ginac.de/${P}.tar.bz2"
+HOMEPAGE="http://www.ginac.de/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+RDEPEND=">=sci-libs/cln-1.2.2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen
+ media-gfx/transfig
+ virtual/texi2dvi
+ dev-texlive/texlive-fontsrecommended
+ )"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.5.1-pkgconfig.patch )
+
+src_configure() {
+ local myeconfargs=( --disable-rpath )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ if use doc; then
+ export VARTEXFONTS="${T}"/fonts
+ cd "${BUILD_DIR}/doc/reference"
+ emake html pdf
+ cd "${BUILD_DIR}/doc/tutorial"
+ emake ginac.pdf ginac.html
+ fi
+}
+
+src_install() {
+ autotools-utils_src_install
+ if use doc; then
+ cd "${BUILD_DIR}"/doc
+ insinto /usr/share/doc/${PF}
+ newins tutorial/ginac.pdf tutorial.pdf
+ newins reference/reference.pdf reference.pdf
+ insinto /usr/share/doc/${PF}/html/reference
+ doins -r reference/html_files/*
+ insinto /usr/share/doc/${PF}/html
+ newins tutorial/ginac.html tutorial.html
+ insinto /usr/share/doc/${PF}/examples
+ doins "${S}"/doc/examples/*.cpp examples/ginac-examples.*
+ fi
+}