summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2016-01-22 00:00:07 -0800
committerBrian Dolbec <dolsen@gentoo.org>2016-01-23 11:23:04 -0800
commitbae965f73a2419319c8010cf528a963957a4880c (patch)
treeac94fc7317dd9c259872774fa74bd729d1173936
parentdev-python/ssl-fetch: Version bump (diff)
downloadgentoo-bae965f73a2419319c8010cf528a963957a4880c.tar.gz
gentoo-bae965f73a2419319c8010cf528a963957a4880c.tar.bz2
gentoo-bae965f73a2419319c8010cf528a963957a4880c.zip
dev-python/pyGPG: Version bump
Package-Manager: portage-2.2.27
-rw-r--r--dev-python/pyGPG/Manifest1
-rw-r--r--dev-python/pyGPG/pyGPG-0.2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pyGPG/Manifest b/dev-python/pyGPG/Manifest
index 9a891064f462..c050c3bf9565 100644
--- a/dev-python/pyGPG/Manifest
+++ b/dev-python/pyGPG/Manifest
@@ -1 +1,2 @@
DIST pyGPG-0.1.tar.gz 15441 SHA256 c699192606652ebe1a369770d00110baa490c74c3d858ad0513ec55f315e7735 SHA512 58a89fbee4311b89c5515ad1bc1d901057e8acdfdbcf36813f50a766374100a62efe456d52263711e5c2f46957791def9343d94f019e413506cfdbd353602060 WHIRLPOOL 24862897737516945cdc8e41ced589f4ef4b64cdd4a92ddae22c07e9252c0cf8779b685b6cd35fac5b3244d0000d9bade98d661c67ac904639ebc142281551c1
+DIST pyGPG-0.2.tar.gz 15439 SHA256 0c45b408b080c725832463d15a2227da48c4dbd9fa918c8662631adec5b0a08f SHA512 93d892a57a27b254bfdc9778b73d341dfec654c2104c578014628df78c43beaf93eafb571ac544d52f334e63f6e5b8c0cfad7c8a0d585ee7211e8649efce8c67 WHIRLPOOL 81e2bb285b9aef73edbef91b5ac460c048f8826fe480b356d39ba66105905aa02bf73f56b49918fd45b0765bad03361a11c6684303b37df20fb2d23113a3f7e7
diff --git a/dev-python/pyGPG/pyGPG-0.2.ebuild b/dev-python/pyGPG/pyGPG-0.2.ebuild
new file mode 100644
index 000000000000..f2fb3818d1c3
--- /dev/null
+++ b/dev-python/pyGPG/pyGPG-0.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4,3_5})
+
+inherit distutils-r1
+
+EGIT_REPO_URI="git://github.com/dol-sen/pyGPG.git"
+
+DESCRIPTION="A python interface wrapper for gnupg's gpg command"
+HOMEPAGE="https://github.com/dol-sen/pyGPG"
+SRC_URI="https://dev.gentoo.org/~dolsen/releases/pyGPG/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~s390 ~x86"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-crypt/gnupg
+ "
+
+pkg_postinst() {
+ einfo
+ einfo "This is experimental software."
+ einfo "The API's it installs should be considered unstable"
+ einfo "and are subject to change."
+ einfo
+ einfo "This version includes a new gkeys-gpg command"
+ einfo "It can be used as an alternate gpg command for git"
+ einfo "It will set the correct keyring to verify signed commits"
+ einfo "provided the key it needs to verify against is part of the gkeys"
+ einfo "keyring system. It only works for verification, any other call "
+ einfo "to it will re-direct directly to the normal gpg command."
+ einfo
+ einfo "Please file any enhancement requests, or bugs"
+ einfo "at https://github.com/dol-sen/pyGPG/issues"
+ einfo "I am also on IRC @ #gentoo-keys of the freenode network"
+ einfo
+ ewarn "There may be some python 3 compatibility issues still."
+ ewarn "Please help debug/fix/report them in github or bugzilla."
+}