summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Seichter <github@seichter.de>2019-04-07 20:49:29 +0200
committerMichał Górny <mgorny@gentoo.org>2019-04-09 12:50:45 +0200
commitbc29b87df35b61cfcda3ee228365cb823eca5ae1 (patch)
tree693fd2450079e891386854bd18d5396915aebcda
parentdev-util/source-highlight: fix build for Prefix, thanks Olivier Huber (diff)
downloadgentoo-bc29b87df35b61cfcda3ee228365cb823eca5ae1.tar.gz
gentoo-bc29b87df35b61cfcda3ee228365cb823eca5ae1.tar.bz2
gentoo-bc29b87df35b61cfcda3ee228365cb823eca5ae1.zip
dev-python/authres: version bump to 1.1.1
Ebuild for upstream release 1.1.1. Changed EAPI to 7. Signed-off-by: Ralph Seichter <gentoo@seichter.de> Closes: https://bugs.gentoo.org/682778 Package-Manager: Portage-2.3.62, Repoman-2.3.11 RepoMan-Options: --force Closes: https://github.com/gentoo/gentoo/pull/11632 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/authres/Manifest1
-rw-r--r--dev-python/authres/authres-1.1.1.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/authres/Manifest b/dev-python/authres/Manifest
index d1b26a44aace..0ba1a619c7a0 100644
--- a/dev-python/authres/Manifest
+++ b/dev-python/authres/Manifest
@@ -1 +1,2 @@
DIST authres-0.800.tar.gz 19863 BLAKE2B 01f9264a78ef5a3ee9fa1db17dd4fc5d1e849a5f297f610ab0bda09f4900bca15e63d71c2312e12b1e6173213d3eef938dae996c7bcc599de496b6c77001de87 SHA512 d9e73309064e396c51ed55394ce505c21869d267922df55b6723cb6b2409282c7827d35d381877b5f08e037042e015d59246603d51219c829df7b81011499fe7
+DIST authres-1.1.1.tar.gz 23180 BLAKE2B 8ca2e0a0e93da50188d721be1fd60604ec2fdedb117df39c6e74d454d48d008a1627b45acbc18df3bc3c386794d7ac91e31ccca131c9e6e04f6bb34417f64c50 SHA512 61e73e85e524279d5db37375fbe7b1fcf65a24280ef61124a94e4236ce477c225637690e9d424f5ee3fef8b9cd3d26c6d512dfa3c1c8491fa4f4bf266f88ac80
diff --git a/dev-python/authres/authres-1.1.1.ebuild b/dev-python/authres/authres-1.1.1.ebuild
new file mode 100644
index 000000000000..0823667ce457
--- /dev/null
+++ b/dev-python/authres/authres-1.1.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Authentication-Results Headers generation and parsing"
+HOMEPAGE="https://launchpad.net/authentication-results-python https://pypi.org/project/authres/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+python_test() {
+ "${PYTHON}" -c "import sys, authres, doctest; f, t = doctest.testfile('authres/tests'); \
+ sys.exit(bool(f))" || die "Tests fail with ${EPYTHON}"
+}