summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-22 21:26:34 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-22 21:39:56 +0200
commitbcf8d7aa55f856de1cd366e7072ce5b02078441d (patch)
tree15a26d4e678a10211d3de4226fe7167ed8b23030
parentgames-engines/love: Drop old (diff)
downloadgentoo-bcf8d7aa55f856de1cd366e7072ce5b02078441d.tar.gz
gentoo-bcf8d7aa55f856de1cd366e7072ce5b02078441d.tar.bz2
gentoo-bcf8d7aa55f856de1cd366e7072ce5b02078441d.zip
games-arcade/mrrescue: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
-rw-r--r--games-arcade/mrrescue/mrrescue-1.02b-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/games-arcade/mrrescue/mrrescue-1.02b-r1.ebuild b/games-arcade/mrrescue/mrrescue-1.02b-r1.ebuild
new file mode 100644
index 000000000000..f8e65e459789
--- /dev/null
+++ b/games-arcade/mrrescue/mrrescue-1.02b-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils gnome2-utils
+
+DESCRIPTION="Arcade 2d action game based around evacuating civilians from burning buildings"
+HOMEPAGE="http://tangramgames.dk/games/mrrescue/"
+SRC_URI="https://github.com/SimonLarsen/mrrescue/releases/download/v${PV}/${P}-love.zip
+ https://dev.gentoo.org/~hasufell/distfiles/${PN}.png"
+
+LICENSE="CC-BY-SA-3.0 MIT ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="games-engines/love:0"
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${P}-love"
+
+src_install() {
+ local dir=/usr/share/love/${PN}
+
+ exeinto "${dir}"
+ doexe ${PN}.love
+
+ einstalldocs
+
+ doicon -s 64 "${DISTDIR}"/${PN}.png
+ make_wrapper ${PN} "love ${PN}.love" "${dir}"
+ make_desktop_entry ${PN}
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}