summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-05-03 19:05:23 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-05-03 19:44:22 +0200
commitbd2542990d1b0b8b3b68bc6d4c34c3bf64053690 (patch)
treec43316be74433df29018463d2566f5172fc61e4e
parentdev-ml/ppx_pipebang: fix build with ocaml 4.03 (diff)
downloadgentoo-bd2542990d1b0b8b3b68bc6d4c34c3bf64053690.tar.gz
gentoo-bd2542990d1b0b8b3b68bc6d4c34c3bf64053690.tar.bz2
gentoo-bd2542990d1b0b8b3b68bc6d4c34c3bf64053690.zip
dev-ml/ppx_let: fix build with ocaml 4.03
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--dev-ml/ppx_let/files/oc43.patch44
-rw-r--r--dev-ml/ppx_let/ppx_let-113.33.00.ebuild4
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-ml/ppx_let/files/oc43.patch b/dev-ml/ppx_let/files/oc43.patch
new file mode 100644
index 000000000000..294964220944
--- /dev/null
+++ b/dev-ml/ppx_let/files/oc43.patch
@@ -0,0 +1,44 @@
+diff -uNr ppx_let-113.33.00/_oasis ppx_let-113.33.00+4.03/_oasis
+--- ppx_let-113.33.00/_oasis 2016-03-09 16:44:54.000000000 +0100
++++ ppx_let-113.33.00+4.03/_oasis 2016-03-22 15:13:50.000000000 +0100
+@@ -1,8 +1,8 @@
+ OASISFormat: 0.4
+-OCamlVersion: >= 4.02.3
++OCamlVersion: >= 4.03.0
+ FindlibVersion: >= 1.3.2
+ Name: ppx_let
+-Version: 113.33.00
++Version: 113.33.00+4.03
+ Synopsis: Monadic let-bindings
+ Authors: Jane Street Group, LLC <opensource@janestreet.com>
+ Copyrights: (C) 2015-2016 Jane Street Group LLC <opensource@janestreet.com>
+diff -uNr ppx_let-113.33.00/opam ppx_let-113.33.00+4.03/opam
+--- ppx_let-113.33.00/opam 2016-03-18 12:08:01.000000000 +0100
++++ ppx_let-113.33.00+4.03/opam 2016-03-22 17:51:37.000000000 +0100
+@@ -15,4 +15,4 @@
+ "ppx_core"
+ "ppx_driver"
+ ]
+-available: [ ocaml-version >= "4.02.3" ]
++available: [ ocaml-version >= "4.03.0" ]
+diff -uNr ppx_let-113.33.00/src/ppx_let.ml ppx_let-113.33.00+4.03/src/ppx_let.ml
+--- ppx_let-113.33.00/src/ppx_let.ml 2016-03-09 16:44:54.000000000 +0100
++++ ppx_let-113.33.00+4.03/src/ppx_let.ml 2016-03-22 15:13:50.000000000 +0100
+@@ -64,7 +64,7 @@
+ in
+ pexp_apply ~loc
+ (eoperator ~loc (Extension_name.operator_name extension_name))
+- [("", arg); (fn_label, fn)]
++ [(Nolabel, arg); (Labelled fn_label, fn)]
+ ;;
+
+ let maybe_open extension_name ~to_open:module_to_open expr =
+@@ -90,7 +90,7 @@
+ ppat_tuple ~loc [p; acc])
+ in
+ bind_apply ~loc extension_name ~arg:nested_boths
+- ~fn:(pexp_fun ~loc "" None nested_patterns
++ ~fn:(pexp_fun ~loc Nolabel None nested_patterns
+ (maybe_open extension_name ~to_open:open_in_body body))
+ ;;
+
diff --git a/dev-ml/ppx_let/ppx_let-113.33.00.ebuild b/dev-ml/ppx_let/ppx_let-113.33.00.ebuild
index b451b5325ed8..a721168803c1 100644
--- a/dev-ml/ppx_let/ppx_let-113.33.00.ebuild
+++ b/dev-ml/ppx_let/ppx_let-113.33.00.ebuild
@@ -22,6 +22,10 @@ DEPEND="dev-ml/ppx_tools:=
RDEPEND="${DEPEND}"
DEPEND="${DEPEND} dev-ml/opam"
+src_prepare() {
+ has_version '>=dev-lang/ocaml-4.03' && epatch "${FILESDIR}/oc43.patch"
+}
+
src_configure() {
emake setup.exe
OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure