summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-11-10 17:25:26 -0600
committerAustin English <wizardedit@gentoo.org>2016-11-11 13:38:57 -0600
commitbea9a3f52477a99df8b4aaf5cf94c2606fecd11a (patch)
treeed92058d42f95a3832b4fba06fce42be9c0cf403
parentgames-engines/gemrb: remove deprecated games eclass (diff)
downloadgentoo-bea9a3f52477a99df8b4aaf5cf94c2606fecd11a.tar.gz
gentoo-bea9a3f52477a99df8b4aaf5cf94c2606fecd11a.tar.bz2
gentoo-bea9a3f52477a99df8b4aaf5cf94c2606fecd11a.zip
games-engines/nazghul: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.2
-rw-r--r--games-engines/nazghul/nazghul-0.7.1-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/games-engines/nazghul/nazghul-0.7.1-r1.ebuild b/games-engines/nazghul/nazghul-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..3f50e12b2781
--- /dev/null
+++ b/games-engines/nazghul/nazghul-0.7.1-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="A computer role-playing game (CRPG) engine with game called HaximA"
+HOMEPAGE="http://myweb.cableone.net/gmcnutt/nazghul.html"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libpng:0
+ >=media-libs/libsdl-1.2.3[X,sound,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[midi,vorbis,wav]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ ecvs_clean
+
+ default
+}
+
+src_install() {
+ default
+ dodoc doc/{GAME_RULES,GHULSCRIPT,MAP_HACKERS_GUIDE,USERS_GUIDE}
+
+ dodoc doc/*html
+ dodoc doc/*gif
+
+ docinto engine_extension_and_design
+ dodoc doc/engine_extension_and_design/*
+
+ docinto world_building
+ dodoc doc/world_building/*
+
+ doicon icons/haxima.png
+ make_desktop_entry haxima.sh HaximA haxima
+}