summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2016-09-14 15:19:00 -0500
committerMatthias Maier <tamiko@gentoo.org>2016-09-14 16:40:26 -0500
commitbeaa36d50e716ec8e454a15f2c40dfdcf45cd54d (patch)
treef1238b4783d1fb369d285894d6deca5c797e38c7
parentapp-emulation/libvirt: version bump to 2.2.0 (diff)
downloadgentoo-beaa36d50e716ec8e454a15f2c40dfdcf45cd54d.tar.gz
gentoo-beaa36d50e716ec8e454a15f2c40dfdcf45cd54d.tar.bz2
gentoo-beaa36d50e716ec8e454a15f2c40dfdcf45cd54d.zip
dev-python/libvirt-python: version bump to 2.2.0
Package-Manager: portage-2.2.28
-rw-r--r--dev-python/libvirt-python/Manifest1
-rw-r--r--dev-python/libvirt-python/libvirt-python-2.2.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/libvirt-python/Manifest b/dev-python/libvirt-python/Manifest
index 6c662257ad8e..e67765f9217b 100644
--- a/dev-python/libvirt-python/Manifest
+++ b/dev-python/libvirt-python/Manifest
@@ -1,3 +1,4 @@
DIST libvirt-python-1.3.5.tar.gz 168780 SHA256 a0508a57637fd18a3584fb9d2322fb172f65708c9db16e0438a70eb0f36fa5c2 SHA512 e1241e71dc0c574b14c6ecb101ec611f0c8caab6a5f82268882febb7b1382752d350ee0f6c2d648c30c6af3f19ef5b91bb518d8a0bd6ab967807b82dd4cf893f WHIRLPOOL 83a861fd425320214c43b80053444cc273c761e88b2530a10d2e8bfe898b19e1563d9f3b182deabe7fc8a7f445c303fa495123bb28d41caa88954cceff40c453
DIST libvirt-python-2.0.0.tar.gz 170475 SHA256 7816cbc1c6ad140ba643b662825babb1ef586bd3ccfd0b04dfeba4ae2f2d1d40 SHA512 695de54ab79d10900c44d2e12be422692da03436f5f89bd4020f3e114d250a94e13c61d112287f2d0d3d1dfadd7309af501d4226a12925c4295e4b3aae20d88c WHIRLPOOL 48059b5a2c31194369096737d45ded7c64eed14055fb895e5844025c3f888a17473d32c717db5e4c5a84be8623c2f40d67efa87b7a261be68a13a06d9afb272d
DIST libvirt-python-2.1.0.tar.gz 170607 SHA256 74887fa1be60db2701e726da7e01e3bf18ecd3b8d1cfdf2f1f7480e1a1edbacb SHA512 8a031b7572c11f57a16292980188e4da830d1293aa1aab3fa35f9c18746e5628086643d8c6d6450d668d194dd3c792e0a5f61605f96dc11fa430c846e459529a WHIRLPOOL 96f02cc2870a9ecc722da1dbf2aa3f7d01fcbec6b5215329d75664e468d938a6ed7a5ff691618176539edaba0beb6ea0d01b02f328758099b343b86ac9e853e3
+DIST libvirt-python-2.2.0.tar.gz 171557 SHA256 ba6b2eb3f018275e9720498d7b771959c2d51ebd54f6e956de5055f912afea76 SHA512 d3c6679e8e9a7c875c89078733a4a8b25c65d7a37c1bad8ded7bffc1b16cac0c0db93fd5c5bfc8433cd6dd657d5d307a9bb38cc1178ecc5c730f8e03d5d6ae1d WHIRLPOOL 6f5d9360bae2c7611fadecf546c0159ae718cc932c0aa096622d80b58972f4623c7efa7979be7397b7ff4dc3906d3df0bebb5ff62f4d5a239ff45840bae78edb
diff --git a/dev-python/libvirt-python/libvirt-python-2.2.0.ebuild b/dev-python/libvirt-python/libvirt-python-2.2.0.ebuild
new file mode 100644
index 000000000000..4a025bf65e6b
--- /dev/null
+++ b/dev-python/libvirt-python/libvirt-python-2.2.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+AUTOTOOLIZE=yes
+
+MY_P="${P/_rc/-rc}"
+
+inherit eutils distutils-r1
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://libvirt.org/libvirt-python.git"
+ SRC_URI=""
+ KEYWORDS=""
+ RDEPEND="app-emulation/libvirt:=[-python(-)]"
+else
+ SRC_URI="http://libvirt.org/sources/python/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ RDEPEND="app-emulation/libvirt:0/${PV}"
+fi
+S="${WORKDIR}/${P%_rc*}"
+
+DESCRIPTION="libvirt Python bindings"
+HOMEPAGE="http://www.libvirt.org"
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="test"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+# testsuite is currently not included in upstream tarball
+RESTRICT="test"
+
+python_test() {
+ esetup.py test
+}