summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-02-18 17:31:20 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-02-18 17:36:36 -0600
commitbf1d06c93a409672033199f839bc1606ab69f43f (patch)
tree46cbceb41fbc41e4a82884175279c0cf8819538a
parentdev-libs/libunicode: stable 0.4-r2 for ia64, bug #648046 (diff)
downloadgentoo-bf1d06c93a409672033199f839bc1606ab69f43f.tar.gz
gentoo-bf1d06c93a409672033199f839bc1606ab69f43f.tar.bz2
gentoo-bf1d06c93a409672033199f839bc1606ab69f43f.zip
sys-auth/nss-pam-ldapd: 0.9.9 bup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--sys-auth/nss-pam-ldapd/Manifest2
-rw-r--r--sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.9.ebuild (renamed from sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.7.ebuild)54
2 files changed, 46 insertions, 10 deletions
diff --git a/sys-auth/nss-pam-ldapd/Manifest b/sys-auth/nss-pam-ldapd/Manifest
index a1c61609131c..245b9264ea54 100644
--- a/sys-auth/nss-pam-ldapd/Manifest
+++ b/sys-auth/nss-pam-ldapd/Manifest
@@ -1,3 +1,3 @@
DIST nss-pam-ldapd-0.8.14.tar.gz 508949 BLAKE2B ad8532bf86ef93c62394b91b7c3c035dc1090a70b60ab190ed8af012d533e61fe067b4383388af0d3a53142dbc96da3468d2aa09c2a30f92b9cf56434160c6d6 SHA512 70abb1836b5b3304e583fd3b71f11fee7586e181b26f4630779ec1d90b856da6e4fcc76327c51b20a158aa36708dd12ceb5f543a33c826881f2ad3e092f542c9
-DIST nss-pam-ldapd-0.9.7.tar.gz 762743 BLAKE2B 7e0266dc7f1f3086ea52175c2389dc55adff932153990347bfcfc511321aa04c76d873eea048ac4be1d574b9e50bfbb882ddadaf2a6b3be43d6689a1ccef88cd SHA512 2117262f41c4fc54987f9f663ed71126100420ecff391cc280e98d7864094db201a81a4ebf7e5634436982092be3c751971d8aee53e39c42a8572ab57b561284
DIST nss-pam-ldapd-0.9.8.tar.gz 771247 BLAKE2B bef3e5ede2b4747277ee400dfa8be620281e4e2a596acff236008e1f0bf6b79d6e309a4ca4bad852f6b0a8f79888cffcfffe09ddea8fde8e53b8450a894598eb SHA512 f0d24afd4cb5cea8155aa719b598448d3d81a896f7bc431f7d73e0617a7b2aa7e0ceb6de0b50163848c5554d96a3c415226e32a92e64ed91772fec4c64ad135b
+DIST nss-pam-ldapd-0.9.9.tar.gz 772059 BLAKE2B 0c1da79d58f19f0c310c0589ca9f286a73ada025028d1a00df938d40dd1211f4dd5ba694de94a37a3596b64b5f8a511127c359a86a60271eb091082dec69e6bb SHA512 8148467523003da397d03b70bb01e52dbc63b0528540aea1d85f6af2ee8af69300e107617b69608397b210e825a2351cfd61b88c4fa146d2e8e9fb9c5cd358e3
diff --git a/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.7.ebuild b/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.9.ebuild
index 22abd70bba2b..7b25079038a8 100644
--- a/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.7.ebuild
+++ b/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.9.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
PYTHON_COMPAT=(python2_7)
inherit eutils prefix user python-r1 multilib multilib-minimal systemd s6
@@ -12,8 +12,8 @@ SRC_URI="http://arthurdejong.org/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="debug kerberos +pam sasl test +utils"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug kerberos +pam pynslcd sasl test +utils"
COMMON_DEP="
net-nds/openldap[${MULTILIB_USEDEP}]
@@ -21,6 +21,10 @@ COMMON_DEP="
kerberos? ( virtual/krb5[${MULTILIB_USEDEP}] )
virtual/pam[${MULTILIB_USEDEP}]
utils? ( ${PYTHON_DEPS} )
+ pynslcd? (
+ dev-python/python-ldap[${PYTHON_USEDEP}]
+ dev-python/python-daemon[${PYTHON_USEDEP}]
+ )
!sys-auth/nss_ldap
!sys-auth/pam_ldap"
RDEPEND="${COMMON_DEP}"
@@ -33,7 +37,12 @@ DEPEND="${COMMON_DEP}
REQUIRED_USE="
utils? ( ${PYTHON_REQUIRED_USE} )
- test? ( ${PYTHON_REQUIRED_USE} )"
+ test? ( ${PYTHON_REQUIRED_USE} pynslcd )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.9.4-disable-py3-only-linters.patch
+ "${FILESDIR}"/${PN}-0.9.8-pynslcd-module-paths.patch
+)
pkg_setup() {
enewgroup nslcd
@@ -41,9 +50,11 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.9.4-disable-py3-only-linters.patch
- epatch_user
+ cp pynslcd/pynslcd.py "${S}" || die "Copying pynslcd failed"
+
+ default
use utils && python_setup
+ touch pynslcd/__init__.py || die "Could not create __init__.py for pynslcd"
}
multilib_src_configure() {
@@ -57,6 +68,7 @@ multilib_src_configure() {
--with-nslcd-pidfile=/run/nslcd/nslcd.pid
--with-nslcd-socket=/run/nslcd/socket
$(usex x86-fbsd '--with-nss-flavour=' '--with-nss-flavour=' 'freebsd' 'glibc')
+ $(use_enable pynslcd)
$(use_enable debug)
$(use_enable kerberos)
$(use_enable pam)
@@ -89,19 +101,43 @@ multilib_src_install_all() {
if use utils; then
python_moduleinto nslcd
- python_foreach_impl && python_domodule utils/*.py
+ python_foreach_impl python_domodule utils/*.py
for script in chsh getent; do
python_foreach_impl python_newscript utils/${script}.py ${script}.ldap
done
fi
+ if use pynslcd; then
+ rm -rf "${D}"/usr/share/pynslcd
+ python_moduleinto pynslcd
+ python_foreach_impl python_domodule pynslcd/*.py
+ python_scriptinto /usr/sbin
+ python_newscript pynslcd.py pynslcd
+ newinitd "${FILESDIR}"/pynslcd.initd pynslcd
+ fi
systemd_newtmpfilesd "${FILESDIR}"/nslcd-tmpfiles.conf nslcd.conf
systemd_dounit "${FILESDIR}"/nslcd.service
}
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+
+ if use pynslcd; then
+ python_moduleinto pynslcd
+ python_foreach_impl python_domodule pynslcd/*.py
+ fi
+}
+
+python_test() {
+ PYTHONPATH="${S}" emake check
+}
+
multilib_src_test() {
- python_foreach_impl emake check
+ pushd "${BUILD_DIR}"
+ ln -s ../pynslcd/constants.py utils/constants.py
+ python_foreach_impl python_test
+ popd
}
pkg_postinst() {