summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-10-04 11:21:38 +0200
committerMichał Górny <mgorny@gentoo.org>2019-10-04 11:21:38 +0200
commitbf463b56e62ebb5b4660e317a35ae46027aed562 (patch)
treee4edd381da42f72aa7f206bee47f3474d9280bf9
parentdev-lang/ghc: bump up to 8.8.1. no KEYWORDS yet (diff)
downloadgentoo-bf463b56e62ebb5b4660e317a35ae46027aed562.tar.gz
gentoo-bf463b56e62ebb5b4660e317a35ae46027aed562.tar.bz2
gentoo-bf463b56e62ebb5b4660e317a35ae46027aed562.zip
dev-ml/llvm-ocaml: Update 10+ for dylib linking
Pass appropriate arguments to 10+ to link against dylib instead of trying to link to non-existent static libs. This still needs a fix upstream but the ebuild's broken anyway. Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-10.0.0.9999.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-10.0.0.9999.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-10.0.0.9999.ebuild
index 9a84b67cb527..b0d581bd9ff5 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-10.0.0.9999.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-10.0.0.9999.ebuild
@@ -65,8 +65,11 @@ src_configure() {
local mycmakeargs=(
-DLLVM_LIBDIR_SUFFIX=${libdir#lib}
- -DBUILD_SHARED_LIBS=ON
+ -DBUILD_SHARED_LIBS=OFF
+ -DLLVM_BUILD_LLVM_DYLIB=ON
+ -DLLVM_LINK_LLVM_DYLIB=ON
-DLLVM_OCAML_OUT_OF_TREE=ON
+
# cheap hack: LLVM combines both anyway, and the only difference
# is that the former list is explicitly verified at cmake time
-DLLVM_TARGETS_TO_BUILD=""