summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2021-03-14 13:11:29 -0600
committerChristoph Junghans <junghans@gentoo.org>2021-03-14 13:15:02 -0600
commitbf8eded56653b220a499cf667de4007f5582dcfd (patch)
tree68896ffe122aebfa855204b3df4e8e526eff6288
parentsci-chemistry/votca-csg: version bump (diff)
downloadgentoo-bf8eded56653b220a499cf667de4007f5582dcfd.tar.gz
gentoo-bf8eded56653b220a499cf667de4007f5582dcfd.tar.bz2
gentoo-bf8eded56653b220a499cf667de4007f5582dcfd.zip
sci-libs/libint: enable shared libs
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Christoph Junghans <junghans@gentoo.org>
-rw-r--r--sci-libs/libint/libint-2.6.0-r2.ebuild1
-rw-r--r--sci-libs/libint/libint-2.6.0-r3.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/sci-libs/libint/libint-2.6.0-r2.ebuild b/sci-libs/libint/libint-2.6.0-r2.ebuild
index a07d7360830c..6646dd1f96d1 100644
--- a/sci-libs/libint/libint-2.6.0-r2.ebuild
+++ b/sci-libs/libint/libint-2.6.0-r2.ebuild
@@ -42,6 +42,7 @@ src_configure() {
--with-g12-max-am=5 --with-g12-opt-am=3 \
--with-g12dkh-max-am=5 --with-g12dkh-opt-am=3 \
--enable-contracted-ints \
+ --enable-shared
$(use_enable static-libs static)
}
diff --git a/sci-libs/libint/libint-2.6.0-r3.ebuild b/sci-libs/libint/libint-2.6.0-r3.ebuild
new file mode 100644
index 000000000000..686add02d2df
--- /dev/null
+++ b/sci-libs/libint/libint-2.6.0-r3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools eutils fortran-2 toolchain-funcs
+
+DESCRIPTION="Matrix elements (integrals) evaluation over Cartesian Gaussian functions"
+HOMEPAGE="https://github.com/evaleev/libint"
+SRC_URI="https://github.com/evaleev/libint/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="2"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs doc"
+
+DEPEND="
+ dev-libs/boost
+ dev-libs/gmp[cxx]
+ doc? (
+ dev-texlive/texlive-latex
+ dev-tex/latex2html
+ )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-cxx=$(tc-getCXX) \
+ --with-cxx-optflags="${CXXFLAGS}" \
+ --with-cxxgen-optflags="${CXXFLAGS}" \
+ --with-cxxdepend=$(tc-getCXX) \
+ --with-ranlib=$(tc-getRANLIB) \
+ --with-ar=$(tc-getAR) \
+ --with-ld=$(tc-getLD) \
+ --enable-eri=2 --enable-eri3=2 --enable-eri2=2 \
+ --with-eri-max-am=7,5,4 --with-eri-opt-am=3 \
+ --with-eri3-max-am=7 --with-eri2-max-am=7 \
+ --with-g12-max-am=5 --with-g12-opt-am=3 \
+ --with-g12dkh-max-am=5 --with-g12dkh-opt-am=3 \
+ --enable-contracted-ints \
+ --enable-shared
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}"
+
+ use doc && emake html pdf
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ DOCS=( doc/progman/progman.pdf )
+ HTML_DOCS=( doc/progman/progman/*.{html,png,css} )
+ einstalldocs
+ fi
+}