summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2018-10-10 22:51:36 +0300
committerMikle Kolyada <zlogene@gentoo.org>2018-10-10 22:51:36 +0300
commitbfcc83a5a551175bf09465547ed6d326d62cdf17 (patch)
treeef1acae94012710af9bc1d1f80981d853603245d
parentprofiles: last-riting dev-python/flask-restless (diff)
downloadgentoo-bfcc83a5a551175bf09465547ed6d326d62cdf17.tar.gz
gentoo-bfcc83a5a551175bf09465547ed6d326d62cdf17.tar.bz2
gentoo-bfcc83a5a551175bf09465547ed6d326d62cdf17.zip
app-text/zathura-djvu: Version bump (v0.2.8)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
-rw-r--r--app-text/zathura-djvu/Manifest1
-rw-r--r--app-text/zathura-djvu/zathura-djvu-0.2.8.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-text/zathura-djvu/Manifest b/app-text/zathura-djvu/Manifest
index dfda93333193..7773f93dfd89 100644
--- a/app-text/zathura-djvu/Manifest
+++ b/app-text/zathura-djvu/Manifest
@@ -1,2 +1,3 @@
DIST zathura-djvu-0.2.6.tar.gz 11137 BLAKE2B 23efc23cd53068abb3e118d6dc9b1e875c3f292d2e7ab49abbf6c599d6241c37959e9f74ac2b0f06838cadca0a07e39e1dda2e188f6861b72d4cd7a4bb1fcc62 SHA512 8534faa0de896ffea8d8d6f2d0c22697f2fd6ae3f73e955f5077e0a0656c13fd8823580f1b89c4b5aebb5189c69642ef690fc9167be178ce9533e9bb5d483dac
DIST zathura-djvu-0.2.7.tar.gz 10909 BLAKE2B 6a55927aa99ec5d29b8f24922c4871c050c25f6c166ee3435390488deefd13f1f81f4286a0c3cd348e4f550e1b4082b9a7c5c7cce40371f8fb62074c87a2d372 SHA512 f0a33f53caced4cb90354e431d180a3b357db300ba5a376051e45f5409e8476105640e92768c2a31bdbbb0b37dea05df24a6489799c556e30336013f807b28b6
+DIST zathura-djvu-0.2.8.tar.xz 8860 BLAKE2B ea6eb70d7350ea388043c9ceb8ef8602030d17e4dabc353ac7346ba11c2d8f105bd235eee90823818fc1d4d5a9ca16755bb56a1e1b8aa633a79802ca2c3e92f2 SHA512 ec51d339a01e7f2d063d21ab0e32624770398a21727fe6714b8fa8f9a1ef46909d58fa26c4a50430234f04377cce076312ebefb8a6cbdc28ba5de1c205d944a9
diff --git a/app-text/zathura-djvu/zathura-djvu-0.2.8.ebuild b/app-text/zathura-djvu/zathura-djvu-0.2.8.ebuild
new file mode 100644
index 000000000000..71439fb37996
--- /dev/null
+++ b/app-text/zathura-djvu/zathura-djvu-0.2.8.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils meson xdg-utils
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.pwmt.org/pwmt/zathura-djvu.git"
+ EGIT_BRANCH="develop"
+else
+ KEYWORDS="~amd64 ~arm ~x86"
+ SRC_URI="https://pwmt.org/projects/zathura-djvu/download/${P}.tar.xz"
+fi
+
+DESCRIPTION="DjVu plug-in for zathura"
+HOMEPAGE="https://pwmt.org/projects/zathura-djvu/"
+
+LICENSE="ZLIB"
+SLOT="0"
+
+DEPEND="app-text/djvu
+ >=app-text/zathura-0.3.9
+ dev-libs/girara
+ dev-libs/glib:2
+ x11-libs/cairo"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="virtual/pkgconfig"
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}