summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorneeshy <neeshy@tfwno.gf>2020-06-02 14:10:22 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-06-02 14:13:44 +0300
commitc01bddeb5c48a993a8e906e9f34f4849458dbd02 (patch)
tree0bed221cfd857d722d5b00eb29844dc50b27b88b
parentdev-util/plan9port: bump version to 0_pre20200526 (diff)
downloadgentoo-c01bddeb5c48a993a8e906e9f34f4849458dbd02.tar.gz
gentoo-c01bddeb5c48a993a8e906e9f34f4849458dbd02.tar.bz2
gentoo-c01bddeb5c48a993a8e906e9f34f4849458dbd02.zip
dev-util/plan9port: drop old
Signed-off-by: Nima Sadeghi <neeshy@tfwno.gf> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--dev-util/plan9port/Manifest1
-rw-r--r--dev-util/plan9port/plan9port-20140306-r4.ebuild120
2 files changed, 0 insertions, 121 deletions
diff --git a/dev-util/plan9port/Manifest b/dev-util/plan9port/Manifest
index 60d4aeb16d1b..09b8c7cbe5fa 100644
--- a/dev-util/plan9port/Manifest
+++ b/dev-util/plan9port/Manifest
@@ -1,2 +1 @@
DIST plan9port-a6ad39aaaa36b8aadc5c35bfc803afbde32918c0.tar.gz 23445647 BLAKE2B 4cb0f08fc404c5618c4be0d7e5710e6a8a32fbe010d28a879b1f9575118256492a3ed2b9b744c35dbbb6c6deae405c05fd7b6606254fb94fc2b40b3a8d14fa71 SHA512 4d9f6ce66d3eebb311cbbb0ec27c01d99cc0e19c6ac8a1c511ff00070c085a349b637048cd0066240af975e90f527388dbeba58f4591bf7dcaa673ee5564430f
-DIST plan9port-e78ed7a67bbaa37dc57dfb37219f505c48755e14.tar.gz 23442851 BLAKE2B 89e2a8dcdf650cc3640ef0ba496f1c22e74831fda2e4a51cf8419c496da5a480a10324eb295369e9192defbd3c6411ea351bba1c6bdec5d72bc4ee397da58114 SHA512 3cb126eb0f8c58c76c4da5aaca6b3956b9cc30b1955c1b9db4727a01a46cae696f01b538a47f6f009e955f6ed8f308b60b6519d4184e10b255636ea32a1e9099
diff --git a/dev-util/plan9port/plan9port-20140306-r4.ebuild b/dev-util/plan9port/plan9port-20140306-r4.ebuild
deleted file mode 100644
index 68a51b267f4e..000000000000
--- a/dev-util/plan9port/plan9port-20140306-r4.ebuild
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils multiprocessing toolchain-funcs
-
-MY_HASH="e78ed7a67bbaa37dc57dfb37219f505c48755e14"
-MY_P="${PN}-${MY_HASH}"
-
-DESCRIPTION="Port of many Plan 9 programs and libraries"
-HOMEPAGE="http://swtch.com/plan9port/"
-SRC_URI="https://github.com/9fans/${PN}/archive/${MY_HASH}.tar.gz -> ${MY_P}.tar.gz"
-
-LICENSE="9base BSD-4 MIT LGPL-2.1 BigelowHolmes"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="X aqua truetype"
-REQUIRED_USE="?? ( X aqua )"
-
-DEPEND="X? ( x11-apps/xauth )
- truetype? ( media-libs/freetype
- media-libs/fontconfig )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-PLAN9=/usr/lib/plan9
-EPLAN9="${EPREFIX}"${PLAN9}
-QA_MULTILIB_PATHS="${PLAN9}/.*/.*"
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-"{noexecstack,cflags,builderr}".patch"
- case ${CHOST} in
- *freebsd10.*) # patch 9l to use -pthread also on FreeBSD-10
- epatch "${FILESDIR}/${PN}-freebsd-10.patch" ;;
- *apple*)
- sed -i 's/--noexecstack/-noexecstack/' src/mkhdr ||
- die "Failed to sed AFLAGS" ;;
- esac
-
- # don't hardcode /bin and /usr/bin in PATH
- sed -i '/PATH/s,/bin:/usr/bin:,,' INSTALL || die "sed on INSTALL failed"
-
- # don't hardcode /usr/{,local/}include and prefix /usr/include/*
- for f in src/cmd/fontsrv/freetyperules.sh INSTALL \
- $(find -name makefile); do
- sed -r -i -e 's,-I/usr(|/local)/include ,,g' \
- -e "s,-I/usr(|/local)/include,-I${EPREFIX}/usr\1/include,g" ${f} \
- || die "sed on ${f} failed"
- done
-
- # Fix paths, done in place of ./INSTALL -c
- einfo "Fixing hard-coded /usr/local/plan9 paths"
- grep --null -l -r '/usr/local/plan9' |
- xargs --null sed -i "s,/usr/local/plan9,${EPLAN9},g"
-}
-
-src_configure() {
- local myconf=()
- if use X; then
- myconf+=("X11=${EPREFIX}/usr" WSYSTYPE=x11)
- elif use aqua; then
- local wsystype=$(echo ${MACOSX_DEPLOYMENT_TARGET} |
- awk '{if ($1 > 10.5) print "osx-cocoa"; else print "osx"}')
- myconf+=("WSYSTYPE=${wsystype}")
- else
- myconf+=(WSYSTYPE=nowsys)
- fi
-
- if use truetype; then
- myconf+=(FONTSRV=fontsrv)
- else
- myconf+=(FONTSRV=)
- fi
- printf '%s\n' "${myconf[@]}" >> LOCAL.config
-}
-
-src_compile() {
- export NPROC=$(makeopts_jobs)
- export CC9=$(tc-getCC)
-
- # The INSTALL script builds mk then [re]builds everything using that
- einfo "Compiling Plan 9 from User Space can take a very long time"
- einfo "depending on the speed of your computer. Please be patient!"
- ./INSTALL -b || die "Please report bugs to bugs.gentoo.org, NOT Plan9Port."
-}
-
-src_install() {
- dodir "${PLAN9}"
-
- # P9P's man does not handle compression
- docompress -x $PLAN9/man
-
- # do* plays with the executable bit, and we should not modify them
- cp -a * "${ED}/${PLAN9}"
-
- # build the environment variables and install them in env.d
- cat > "${T}/60plan9" <<-EOF
- PLAN9="${EPLAN9}"
- PATH="${EPLAN9}/bin"
- ROOTPATH="${EPLAN9}/bin"
- MANPATH="${EPLAN9}/man"
- EOF
- doenvd "${T}/60plan9"
-}
-
-pkg_postinst() {
- elog "Plan 9 from User Space has been successfully installed into"
- elog "${PLAN9}. Your PLAN9 and PATH environment variables have"
- elog "also been appropriately set, please use env-update and"
- elog "source /etc/profile to bring that into immediate effect."
- elog
- elog "Please note that ${PLAN9}/bin has been appended to the"
- elog "*end* or your PATH to prevent conflicts. To use the Plan9"
- elog "versions of common UNIX tools, use the absolute path:"
- elog "${PLAN9}/bin or the 9 command (eg: 9 troff)"
- elog
- elog "Please report any bugs to bugs.gentoo.org, NOT Plan9Port."
-}