summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2019-12-11 22:41:29 +0100
committerJoerg Bornkessel <hd_brummy@gentoo.org>2019-12-11 23:16:19 +0100
commitc0984c258ee69485d7b34963c9f60c9e8e58e50b (patch)
tree9fed2c9b7d909036c243643782668ba1e3896015
parentsys-cluster/lustre: Initial import (diff)
downloadgentoo-c0984c258ee69485d7b34963c9f60c9e8e58e50b.tar.gz
gentoo-c0984c258ee69485d7b34963c9f60c9e8e58e50b.tar.bz2
gentoo-c0984c258ee69485d7b34963c9f60c9e8e58e50b.zip
media-plugins/vdr-extb: fixed mirror://vdrfiles is dead
added new src_uri to fix dead mirror Bug: https://bugs.gentoo.org/695898 Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org>
-rw-r--r--media-plugins/vdr-extb/vdr-extb-0.3.1.ebuild24
1 files changed, 11 insertions, 13 deletions
diff --git a/media-plugins/vdr-extb/vdr-extb-0.3.1.ebuild b/media-plugins/vdr-extb/vdr-extb-0.3.1.ebuild
index 70c48ee88c03..ad6f148be980 100644
--- a/media-plugins/vdr-extb/vdr-extb-0.3.1.ebuild
+++ b/media-plugins/vdr-extb/vdr-extb-0.3.1.ebuild
@@ -1,23 +1,23 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit vdr-plugin-2
DESCRIPTION="VDR Plugin: used to control the VDR Extension Board"
-HOMEPAGE="http://www.deltab.de/content/view/74/76/"
-SRC_URI="http://www.deltab.de/component/option,com_docman/task,doc_download/gid,102/ -> "${P}".tar.gz
- mirror://vdrfiles/${PN}/extb_firmware_1.08_lircd.conf.zip
- mirror://vdrfiles/${PN}/extb.tar.gz"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="http://vdr.websitec.de/download/${PN}/${P}.tar.gz
+ http://vdr.websitec.de/download/${PN}/extb_firmware_1.08_lircd.conf.zip
+ http://vdr.websitec.de/download/${PN}/extb.tar.gz"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=">=media-video/vdr-1.6.0
- app-misc/lirc"
+DEPEND="app-misc/lirc
+ media-video/vdr"
RDEPEND="${DEPEND}"
src_prepare() {
@@ -27,8 +27,8 @@ src_prepare() {
-e "s:\$(LDLIBS):\$(LDFLAGS) \$(LDLIBS):"
cd "${WORKDIR}"
- epatch "${FILESDIR}/${P}-gentoo.diff"
- epatch "${FILESDIR}/${P}_vdr-1.7.13.diff"
+ eapply -p0 "${FILESDIR}/${P}-gentoo.diff"
+ eapply -p0 "${FILESDIR}/${P}_vdr-1.7.13.diff"
}
src_compile() {
@@ -39,8 +39,7 @@ src_compile() {
src_install() {
vdr-plugin-2_src_install
- dodoc README.de
- dodoc "${WORKDIR}/lircd.conf.extb_FW1.08"
+ dodoc README.de "${WORKDIR}/lircd.conf.extb_FW1.08"
docinto wakeup
dodoc "${S}/wakeup/README.de"
@@ -62,10 +61,9 @@ src_install() {
pkg_postinst() {
vdr-plugin-2_pkg_postinst
- einfo
einfo "You need to upload the included firmware (1.08)"
einfo "(you will find it in /usr/share/extb/)"
einfo "into the extension board and update your lircd.conf"
einfo "See the supplied lircd.conf.extb_FW1.08 in"
- einfo "/usr/share/doc/vdrplugin-extb"
+ einfo "/usr/share/doc/${PF}"
}