summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-04-19 22:56:26 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-04-19 22:56:39 +0200
commitc0f1dbc9f9a07513ae37252840fccc77cf30a217 (patch)
tree26c694de2f7444bf9777a607c2b1f36f4167f382
parentnet-misc/putty: Moved icons tarball to my own devspace (diff)
downloadgentoo-c0f1dbc9f9a07513ae37252840fccc77cf30a217.tar.gz
gentoo-c0f1dbc9f9a07513ae37252840fccc77cf30a217.tar.bz2
gentoo-c0f1dbc9f9a07513ae37252840fccc77cf30a217.zip
sys-apps/util-linux: Added "magic" USE flag for sys-apps/file dep
Bug: https://bugs.gentoo.org/784188 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--sys-apps/util-linux/util-linux-2.35.2.ebuild5
-rw-r--r--sys-apps/util-linux/util-linux-2.36.2.ebuild5
-rw-r--r--sys-apps/util-linux/util-linux-2.37_rc1.ebuild5
-rw-r--r--sys-apps/util-linux/util-linux-9999.ebuild5
4 files changed, 12 insertions, 8 deletions
diff --git a/sys-apps/util-linux/util-linux-2.35.2.ebuild b/sys-apps/util-linux/util-linux-2.35.2.ebuild
index fe2ccfedf430..7a0ab5050bf6 100644
--- a/sys-apps/util-linux/util-linux-2.35.2.ebuild
+++ b/sys-apps/util-linux/util-linux-2.35.2.ebuild
@@ -25,7 +25,7 @@ HOMEPAGE="https://www.kernel.org/pub/linux/utils/util-linux/ https://github.com/
LICENSE="GPL-2 GPL-3 LGPL-2.1 BSD-4 MIT public-domain"
SLOT="0"
-IUSE="audit build caps +cramfs cryptsetup fdformat hardlink kill +logger ncurses nls pam python +readline selinux slang static-libs su +suid systemd test tty-helpers udev unicode userland_GNU"
+IUSE="audit build caps +cramfs cryptsetup fdformat hardlink kill +logger magic ncurses nls pam python +readline selinux slang static-libs su +suid systemd test tty-helpers udev unicode userland_GNU"
# Most lib deps here are related to programs rather than our libs,
# so we rarely need to specify ${MULTILIB_USEDEP}.
@@ -37,8 +37,8 @@ RDEPEND="
cryptsetup? ( sys-fs/cryptsetup )
hardlink? ( dev-libs/libpcre2:= )
ncurses? (
- sys-apps/file:0=
>=sys-libs/ncurses-5.2-r2:0=[unicode?]
+ magic? ( sys-apps/file:0= )
)
nls? ( virtual/libintl[${MULTILIB_USEDEP}] )
pam? ( sys-libs/pam )
@@ -167,6 +167,7 @@ multilib_src_configure() {
$(multilib_native_use_with slang)
$(multilib_native_use_with systemd)
$(multilib_native_use_with udev)
+ $(multilib_native_usex ncurses "$(use_with libmagic magic)" '--without-libmagic')
$(multilib_native_usex ncurses "$(use_with unicode ncursesw)" '--without-ncursesw')
$(multilib_native_usex ncurses "$(use_with !unicode ncurses)" '--without-ncurses')
$(multilib_native_use_with audit)
diff --git a/sys-apps/util-linux/util-linux-2.36.2.ebuild b/sys-apps/util-linux/util-linux-2.36.2.ebuild
index 59987ec8e8fd..1e8eeb483301 100644
--- a/sys-apps/util-linux/util-linux-2.36.2.ebuild
+++ b/sys-apps/util-linux/util-linux-2.36.2.ebuild
@@ -25,7 +25,7 @@ HOMEPAGE="https://www.kernel.org/pub/linux/utils/util-linux/ https://github.com/
LICENSE="GPL-2 GPL-3 LGPL-2.1 BSD-4 MIT public-domain"
SLOT="0"
-IUSE="audit build caps +cramfs cryptsetup fdformat hardlink kill +logger ncurses nls pam python +readline selinux slang static-libs su +suid systemd test tty-helpers udev unicode userland_GNU"
+IUSE="audit build caps +cramfs cryptsetup fdformat hardlink kill +logger magic ncurses nls pam python +readline selinux slang static-libs su +suid systemd test tty-helpers udev unicode userland_GNU"
# Most lib deps here are related to programs rather than our libs,
# so we rarely need to specify ${MULTILIB_USEDEP}.
@@ -37,8 +37,8 @@ RDEPEND="
cryptsetup? ( sys-fs/cryptsetup )
hardlink? ( dev-libs/libpcre2:= )
ncurses? (
- sys-apps/file:0=
>=sys-libs/ncurses-5.2-r2:0=[unicode?]
+ magic? ( sys-apps/file:0= )
)
nls? ( virtual/libintl[${MULTILIB_USEDEP}] )
pam? ( sys-libs/pam )
@@ -163,6 +163,7 @@ multilib_src_configure() {
$(multilib_native_use_with slang)
$(multilib_native_use_with systemd)
$(multilib_native_use_with udev)
+ $(multilib_native_usex ncurses "$(use_with libmagic magic)" '--without-libmagic')
$(multilib_native_usex ncurses "$(use_with unicode ncursesw)" '--without-ncursesw')
$(multilib_native_usex ncurses "$(use_with !unicode ncurses)" '--without-ncurses')
$(multilib_native_use_with audit)
diff --git a/sys-apps/util-linux/util-linux-2.37_rc1.ebuild b/sys-apps/util-linux/util-linux-2.37_rc1.ebuild
index ee10c1819a4b..3339774e6b95 100644
--- a/sys-apps/util-linux/util-linux-2.37_rc1.ebuild
+++ b/sys-apps/util-linux/util-linux-2.37_rc1.ebuild
@@ -26,7 +26,7 @@ HOMEPAGE="https://www.kernel.org/pub/linux/utils/util-linux/ https://github.com/
LICENSE="GPL-2 GPL-3 LGPL-2.1 BSD-4 MIT public-domain"
SLOT="0"
-IUSE="audit build caps +cramfs cryptsetup fdformat hardlink kill +logger ncurses nls pam python +readline selinux slang static-libs su +suid systemd test tty-helpers udev unicode userland_GNU"
+IUSE="audit build caps +cramfs cryptsetup fdformat hardlink kill +logger magic ncurses nls pam python +readline selinux slang static-libs su +suid systemd test tty-helpers udev unicode userland_GNU"
# Most lib deps here are related to programs rather than our libs,
# so we rarely need to specify ${MULTILIB_USEDEP}.
@@ -38,8 +38,8 @@ RDEPEND="
cryptsetup? ( sys-fs/cryptsetup )
hardlink? ( dev-libs/libpcre2:= )
ncurses? (
- sys-apps/file:0=
>=sys-libs/ncurses-5.2-r2:0=[unicode?]
+ magic? ( sys-apps/file:0= )
)
nls? ( virtual/libintl[${MULTILIB_USEDEP}] )
pam? ( sys-libs/pam )
@@ -192,6 +192,7 @@ multilib_src_configure() {
$(multilib_native_use_with slang)
$(multilib_native_use_with systemd)
$(multilib_native_use_with udev)
+ $(multilib_native_usex ncurses "$(use_with libmagic magic)" '--without-libmagic')
$(multilib_native_usex ncurses "$(use_with unicode ncursesw)" '--without-ncursesw')
$(multilib_native_usex ncurses "$(use_with !unicode ncurses)" '--without-ncurses')
$(multilib_native_use_with audit)
diff --git a/sys-apps/util-linux/util-linux-9999.ebuild b/sys-apps/util-linux/util-linux-9999.ebuild
index ee10c1819a4b..3339774e6b95 100644
--- a/sys-apps/util-linux/util-linux-9999.ebuild
+++ b/sys-apps/util-linux/util-linux-9999.ebuild
@@ -26,7 +26,7 @@ HOMEPAGE="https://www.kernel.org/pub/linux/utils/util-linux/ https://github.com/
LICENSE="GPL-2 GPL-3 LGPL-2.1 BSD-4 MIT public-domain"
SLOT="0"
-IUSE="audit build caps +cramfs cryptsetup fdformat hardlink kill +logger ncurses nls pam python +readline selinux slang static-libs su +suid systemd test tty-helpers udev unicode userland_GNU"
+IUSE="audit build caps +cramfs cryptsetup fdformat hardlink kill +logger magic ncurses nls pam python +readline selinux slang static-libs su +suid systemd test tty-helpers udev unicode userland_GNU"
# Most lib deps here are related to programs rather than our libs,
# so we rarely need to specify ${MULTILIB_USEDEP}.
@@ -38,8 +38,8 @@ RDEPEND="
cryptsetup? ( sys-fs/cryptsetup )
hardlink? ( dev-libs/libpcre2:= )
ncurses? (
- sys-apps/file:0=
>=sys-libs/ncurses-5.2-r2:0=[unicode?]
+ magic? ( sys-apps/file:0= )
)
nls? ( virtual/libintl[${MULTILIB_USEDEP}] )
pam? ( sys-libs/pam )
@@ -192,6 +192,7 @@ multilib_src_configure() {
$(multilib_native_use_with slang)
$(multilib_native_use_with systemd)
$(multilib_native_use_with udev)
+ $(multilib_native_usex ncurses "$(use_with libmagic magic)" '--without-libmagic')
$(multilib_native_usex ncurses "$(use_with unicode ncursesw)" '--without-ncursesw')
$(multilib_native_usex ncurses "$(use_with !unicode ncurses)" '--without-ncurses')
$(multilib_native_use_with audit)