summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-11 05:21:59 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-11 06:07:56 +0100
commitc11505f5ab9f96e80b99f2e20132efcf213528ed (patch)
tree293fd88031d9184b2f36dbe1216842e19d7c710b
parentdev-util/meson: 0.53.0 bump (diff)
downloadgentoo-c11505f5ab9f96e80b99f2e20132efcf213528ed.tar.gz
gentoo-c11505f5ab9f96e80b99f2e20132efcf213528ed.tar.bz2
gentoo-c11505f5ab9f96e80b99f2e20132efcf213528ed.zip
dev-python/hypothesis: Bump to 5.1.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-5.1.3.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index a15c888016fe..8fbc133eb6d8 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -5,3 +5,4 @@ DIST hypothesis-python-4.55.4.tar.gz 9004357 BLAKE2B 93fe51581f044cf5f416d9b74b8
DIST hypothesis-python-4.57.1.tar.gz 9005030 BLAKE2B 3d318896cbe2d24fa6847e764a109791d3acf3821852f8e170991b0be5b069f166e16bdacf7a82fbe49bd9db5188315cdec7cdb4592647571233949ec5732991 SHA512 28622ce8a1d89d09df65f3fbf7e92a1ad98dac140ab646fe11fcb15e6aa9a9672eb51d459f984384d92b819f902de911b06cec2542582d529dd556d2f99ed952
DIST hypothesis-python-5.1.1.tar.gz 8989696 BLAKE2B b2a231088579d0e3220af915f61d0c92dba7943fcfb6e3324a4a87c189fb44e83bdceb82d1e3601b20f219c65e010cc99d70daf7b042df170ce1536d1380d373 SHA512 dcc3a164f5e04f172fd49f9f21cf7c90cba4cb98b770449b167d0fde65eee88be5b352ddb1a2e254f5220191e3c6171b25e4065c21119df12ee7b6935301e512
DIST hypothesis-python-5.1.2.tar.gz 8989829 BLAKE2B 7063b859c8c180412b2d9b2641faefc861e52444b45d4bc455ba8309f44ee24c27e6c9a6d18e93fb0455a93d09d8b30a0d313313212436227f989ad7dd0d1b87 SHA512 48150a3ea6d1c6270cf016a363f110f29e6e2adc2bfa98947581dc963a0a19398609c21251f821c9e741e743411a989730000bff83d9c5a1b95b805408e32df1
+DIST hypothesis-python-5.1.3.tar.gz 8989332 BLAKE2B a86409b0620b3821aae8f23f0473be08ed1152140f05c2ebcb3f226cc133fdbbb617856c768bc6034bcf25e6603e9e72b1b885df116fb9dfce7164018792fb99 SHA512 dd854158c1e903562c7aa101fe7810837816102b1f5dd840ec3d5df9abd9c1463d05adab79ef428749ea2a5d1a425150971d23ae3259b71baf0e0e8a8a9a3bb8
diff --git a/dev-python/hypothesis/hypothesis-5.1.3.ebuild b/dev-python/hypothesis/hypothesis-5.1.3.ebuild
new file mode 100644
index 000000000000..24078c547ce7
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-5.1.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.3[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+src_prepare() {
+ # avoid pytest-xdist dep for one test
+ sed -i -e 's:test_prints_statistics_given_option_under_xdist:_&:' \
+ tests/pytest/test_statistics.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ pytest -vv tests/cover tests/pytest tests/quality ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}