summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2019-09-21 23:03:25 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-09-24 06:40:01 +0300
commitc2359dbf56677aa00886d3b825cb0b9134811fd9 (patch)
tree2d254c9c76cdf35b59c4d633bd64c67809d0f28c
parentapp-misc/vcontrold: version bump 0.98.8 (diff)
downloadgentoo-c2359dbf56677aa00886d3b825cb0b9134811fd9.tar.gz
gentoo-c2359dbf56677aa00886d3b825cb0b9134811fd9.tar.bz2
gentoo-c2359dbf56677aa00886d3b825cb0b9134811fd9.zip
net-im/libcommuni: bump to version 3.5.0_p20190110
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Closes: https://github.com/gentoo/gentoo/pull/12999 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--net-im/libcommuni/Manifest1
-rw-r--r--net-im/libcommuni/libcommuni-3.5.0_p20190110.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/net-im/libcommuni/Manifest b/net-im/libcommuni/Manifest
index 7670d11af66f..6d372f546817 100644
--- a/net-im/libcommuni/Manifest
+++ b/net-im/libcommuni/Manifest
@@ -1 +1,2 @@
DIST libcommuni-3.5.0_p20180116.tar.gz 471286 BLAKE2B 9f89a5eea2444c207b54f6b820c7cef89ff2e578d34ad751fdbfe558af2bcf0e52238ef63b244fb321baa7716c0119ca084c547cc0161a08b46af4c9d604dd0e SHA512 f7ce9c92acbd67b3d75b9b7fc1cef55796a3d44294024da591c7b0c21fc065ec484dbc6a4c83af96fcb6fd6e725a7b6ed4219bd09e2aa0de303b82d64741efba
+DIST libcommuni-3.5.0_p20190110.tar.gz 471278 BLAKE2B 2836a5ae01b08aac624c899a40712a9c452fc5b8f242906063936e48bd59306758cc70ea07beaf8488d228d6029c8128e343bbd59b1bfeff9bb2dccda0153b59 SHA512 9da065ef6b0589f7406d8c66b46f9f8d3d16325b59b7281153233b1a8d2bf98cdd35ee4e416237ac760dfc07531578aa7432226932976b9bbf36209bed5db72c
diff --git a/net-im/libcommuni/libcommuni-3.5.0_p20190110.ebuild b/net-im/libcommuni/libcommuni-3.5.0_p20190110.ebuild
new file mode 100644
index 000000000000..484a8cc0e917
--- /dev/null
+++ b/net-im/libcommuni/libcommuni-3.5.0_p20190110.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_COMMIT="88bb0fcdaab5bdd1176a3b6b485a6415a137ec27"
+
+inherit qmake-utils
+
+DESCRIPTION="A cross-platform IRC framework written with Qt"
+HOMEPAGE="https://communi.github.io/"
+SRC_URI="https://github.com/communi/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples qml test +uchardet"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ examples? ( dev-qt/qtgui:5[xcb] )
+ uchardet? ( app-i18n/uchardet )
+ !uchardet? ( dev-libs/icu:= )
+"
+
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-qt/qttest:5 )
+"
+
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+
+src_prepare() {
+ default
+
+ # Currently the test tst_IrcLagTimer fails, so disabling
+ # See: https://github.com/communi/libcommuni/issues/63
+ sed -e '/irclagtimer/d' -i tests/auto/auto.pro || die
+}
+
+src_configure() {
+ local myqmakeargs=( libcommuni.pro
+ # Disables compile run-time benchmarks, as they don't make any sense
+ -config no_benchmarks
+ # Is needed for fixing the QA Notice: The following files contain insecure RUNPATHs
+ -config no_rpath
+ # Compile libcommuni always in Release mode, as Debug seems to do nothing
+ -config release
+ # Don't silence all compile messages
+ -config verbose
+ -config $(usex examples '' 'no_')examples
+ -config $(usex qml '' 'no_')install_imports
+ -config $(usex qml '' 'no_')install_qml
+ -config $(usex test '' 'no_')tests
+ -config $(usex uchardet 'no_' '')icu
+ -config $(usex uchardet '' 'no_')uchardet )
+
+ eqmake5 "${myqmakeargs[@]}"
+}
+
+src_test() {
+ # This is a hack to delete the existing LD_LIBRARY_PATH and set a new one,
+ # otherwise a test will fail, because it uses the system installed lib instead of the new compiled lib.
+ # The test will fail, when libcommuni is emerged with USE="uchardet" and
+ # libcommuni is already installed with USE="-uchardat", or the other way around.
+ find "${S}" -type f -name 'target_wrapper.sh' -exec sed -i -e "/.*LD_LIBRARY_PATH.*/d" {} \; || die
+ local -x LD_LIBRARY_PATH="${S}/lib"
+
+ default
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+
+ if use examples; then
+ local examples=( "bot" "client" "minimal" "qmlbot" "quick" )
+ for example in ${examples[@]}; do
+ newbin examples/"${example}"/"${example}" libcommuni."${example}"
+ done
+ fi
+
+ einstalldocs
+}