summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-09-09 09:04:59 +0200
committerMichał Górny <mgorny@gentoo.org>2017-09-09 09:23:33 +0200
commitc291d48af72cfbc8aa08c340bc5e977d744746cb (patch)
tree09b51c4cccaedeaafc4c10b9695e331806395a7a
parentdev-ruby/rails: add rails 5.0.6 (diff)
downloadgentoo-c291d48af72cfbc8aa08c340bc5e977d744746cb.tar.gz
gentoo-c291d48af72cfbc8aa08c340bc5e977d744746cb.tar.bz2
gentoo-c291d48af72cfbc8aa08c340bc5e977d744746cb.zip
xfce-extra/xfce4-xkb-plugin: Bump to 0.8.1
-rw-r--r--xfce-extra/xfce4-xkb-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.8.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-xkb-plugin/Manifest b/xfce-extra/xfce4-xkb-plugin/Manifest
index ccf747638db9..59b922f6a5e3 100644
--- a/xfce-extra/xfce4-xkb-plugin/Manifest
+++ b/xfce-extra/xfce4-xkb-plugin/Manifest
@@ -1,2 +1,3 @@
DIST xfce4-xkb-plugin-0.7.1.tar.bz2 837922 SHA256 61fe2e33fe99939d5d06a682e94e40e05ef844c930ad612154090d158b2ce681 SHA512 a6d83a614f85ada6470efbca9d19073ecf31e6531dafff000c1c9d439d7e4a6d02188296810933f28f4cf9b61addd1f99a6a47c8adc6423c44adbf7ffa525094 WHIRLPOOL 1ca8b11311313266be0b4ddea9203f7963734124cf71262e85a9dc8c5b0cc9d56221843df9c14a6d423a8a6adad9fc87b132c47645db86ef7697376c8f31de21
DIST xfce4-xkb-plugin-0.8.0.tar.bz2 835556 SHA256 3b0d3b9f4b7c3e3e7be668e2f7c845b89b16e0ed3db2bacb544a17272682ced0 SHA512 8368b87e4f6459bd3d0c5a805ac1fb191aaf62d18a119f97119b3a1273a23952dcfa5b097542d4e6db645f1509e0a31e0e6152e190e9a2ca32cc61138aca8ded WHIRLPOOL ec7d25f204e5bcd0e21b67e12641e6cdaf6e056ec1d0ad8437e583ef0c5822d17fbf600924600c7ef777db8404dcaeed6ff0f8c8e8ee57eda651c51388ad74da
+DIST xfce4-xkb-plugin-0.8.1.tar.bz2 842814 SHA256 c19ecf126201deb6148741c521124771ad396adc874471512ab5ffe1946567a1 SHA512 4f0362f429489d111544126697880cdb0a768533803a104f73802fe2c5cfbef5efbf6edd658dbb0ef788ae2a3761f1877c191637a6a06d4a5159bc8f71ad524f WHIRLPOOL 46a737c84fb204313a605fac9e57ea5811f1634be82f40d9d53a6f0900ea8e48c1c3ab218bf4152c2af9fce767ceadbb454ffb4c6304e19d2568894414af4d98
diff --git a/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.8.1.ebuild b/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.8.1.ebuild
new file mode 100644
index 000000000000..da18685cab4e
--- /dev/null
+++ b/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.8.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="XKB layout switching panel plug-in for the Xfce desktop environment"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-xkb-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+COMMON_DEPEND="gnome-base/librsvg:=
+ x11-libs/gtk+:3=
+ x11-libs/libwnck:3=
+ x11-libs/libX11:=
+ >=x11-libs/libxklavier-5.4:=
+ xfce-base/garcon:=
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfce4-panel-4.12:=
+ >=xfce-base/xfconf-4.12.1:="
+RDEPEND="${COMMON_DEPEND}
+ x11-apps/setxkbmap
+ >=xfce-base/xfce4-settings-4.11"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ )
+
+ econf "${myconf[@]}"
+}