summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-12-04 11:59:17 +0100
committerPacho Ramos <pacho@gentoo.org>2016-12-04 11:59:17 +0100
commitc2cdce5a758eaad375933233e2877866e3229947 (patch)
tree1ec20febbdf9ff88b5e8ee65a3f15b2a9c3fed80
parentgnome-base/gnome-session: Handle text/markdown mimetype too. (diff)
downloadgentoo-c2cdce5a758eaad375933233e2877866e3229947.tar.gz
gentoo-c2cdce5a758eaad375933233e2877866e3229947.tar.bz2
gentoo-c2cdce5a758eaad375933233e2877866e3229947.zip
gnome-base/gnome-common: People must DEPEND directly on sys-devel/autoconf-archive for the macros when needed instead of relying on dead/obsolete gnome-common ones (#594084)
Package-Manager: portage-2.3.2
-rw-r--r--gnome-base/gnome-common/gnome-common-3.18.0-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnome-base/gnome-common/gnome-common-3.18.0-r1.ebuild b/gnome-base/gnome-common/gnome-common-3.18.0-r1.ebuild
new file mode 100644
index 000000000000..31752240c6bd
--- /dev/null
+++ b/gnome-base/gnome-common/gnome-common-3.18.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="Common files for development of Gnome packages"
+HOMEPAGE="https://git.gnome.org/browse/gnome-common"
+
+LICENSE="GPL-3"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="+autoconf-archive"
+
+RDEPEND=""
+DEPEND=""
+
+src_configure() {
+ # Force people to rely on sys-devel/autoconf-archive, bug #594084
+ gnome2_src_configure --with-autoconf-archive
+}