summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-08-15 08:09:35 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-08-15 08:25:29 +0200
commitc3436b4d33ef29ca3a7b8cf474591ace2dc20e55 (patch)
tree5a472f89ea6ff791094bf5e401317dc416d98606
parentdev-ros/clear_costmap_recovery: Bump to 1.14.2. (diff)
downloadgentoo-c3436b4d33ef29ca3a7b8cf474591ace2dc20e55.tar.gz
gentoo-c3436b4d33ef29ca3a7b8cf474591ace2dc20e55.tar.bz2
gentoo-c3436b4d33ef29ca3a7b8cf474591ace2dc20e55.zip
dev-ros/costmap_2d: Bump to 1.14.2.
Package-Manager: Portage-2.3.7, Repoman-2.3.3
-rw-r--r--dev-ros/costmap_2d/Manifest1
-rw-r--r--dev-ros/costmap_2d/costmap_2d-1.14.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-ros/costmap_2d/Manifest b/dev-ros/costmap_2d/Manifest
index ff346b43cc8f..cd01d19194df 100644
--- a/dev-ros/costmap_2d/Manifest
+++ b/dev-ros/costmap_2d/Manifest
@@ -1 +1,2 @@
DIST navigation-1.14.0.tar.gz 340196 SHA256 3974bb52af21cf0a6e4da8eb231b3101b4c5da700793bdac1cdc97e69d6e5cac SHA512 8ac2048be6d06be1f137aab2e73c5c724e794b9e6125fa70e2283df3790200f7b5203bae12c46e0796523ae58a4f8ede79fd0c1afc09a306a99f450576c7b11a WHIRLPOOL 12e8b7f5043a9473033df772021c3ebae1cdf87bde52988874489e490e7dfdcb07623c588ffd1297fbbd3fc336813fc6f4e9ae812dc80dfcad3062cceb82ef0b
+DIST navigation-1.14.2.tar.gz 345166 SHA256 b8be76079876ff866bce634caf862f1e2fd8e017d82c207b6aed27ca94cf0f6c SHA512 6477104a330a20722fde1634a0d51b1706c9705b4b9415aa9703c99a61d2ce3de97caba24a6b667897e842490c15a6bf2cdbb2f51341febf29d0475b4c0f384b WHIRLPOOL d4fbea98ccf9d7d75ce6cdec54b32132b67a962b047fbf25ea2dd0c2be874e1f981d1f2de66e4a03567680e32c3bd01904429a072b99d9265c50e0baa44cdb5b
diff --git a/dev-ros/costmap_2d/costmap_2d-1.14.2.ebuild b/dev-ros/costmap_2d/costmap_2d-1.14.2.ebuild
new file mode 100644
index 000000000000..cd9d06ed3222
--- /dev/null
+++ b/dev-ros/costmap_2d/costmap_2d-1.14.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs dev-ros/map_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Creates a 2D costmap from sensor data"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+REQUIRED_USE="ros_messages_cxx"
+
+RDEPEND="
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/laser_geometry
+ dev-ros/message_filters
+ dev-ros/nav_msgs
+ dev-ros/pcl_conversions
+ dev-ros/pcl_ros
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/visualization_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf
+ dev-ros/voxel_grid
+ dev-cpp/eigen:3
+ sci-libs/pcl:=
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"