summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaolo Pedroni <PPed72@users.noreply.github.com>2015-11-24 11:47:39 +0100
committerPaolo Pedroni <paolo.pedroni@iol.it>2015-11-26 09:18:38 +0100
commitc368d1945f73911eca37bc077acc9b09d516bb96 (patch)
tree85718b08d2a0ac79f34b058f038c03927f9bc3b4
parentsys-cluster/keepalived: old ebuilds cleanup (diff)
downloadgentoo-c368d1945f73911eca37bc077acc9b09d516bb96.tar.gz
gentoo-c368d1945f73911eca37bc077acc9b09d516bb96.tar.bz2
gentoo-c368d1945f73911eca37bc077acc9b09d516bb96.zip
lxqt-base/liblxqt: Version bump to 0.10.0
Also fixes https://bugs.gentoo.org/show_bug.cgi?id=561420 Thanks to Alpha Bravo <aos@ungwana.de> in bug #564718
-rw-r--r--lxqt-base/liblxqt/liblxqt-0.10.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/lxqt-base/liblxqt/liblxqt-0.10.0.ebuild b/lxqt-base/liblxqt/liblxqt-0.10.0.ebuild
new file mode 100644
index 000000000000..e2d80d246f1b
--- /dev/null
+++ b/lxqt-base/liblxqt/liblxqt-0.10.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="Common base library for the LXQt desktop environment"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+RDEPEND=">=dev-libs/libqtxdg-1.0.0
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ kde-frameworks/kwindowsystem:5[X]
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+"
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ [[ $(gcc-version) < 4.8 ]] && \
+ die 'The active compiler needs to be gcc 4.8 (or newer)'
+ fi
+}