summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2016-11-07 12:22:09 -0800
committerZac Medico <zmedico@gentoo.org>2016-11-07 12:22:09 -0800
commitc38b5c5cd509f908be6b92cf5ff51736b836e3b8 (patch)
tree009a40c34e2b8046f61b130c82fc5258686b937b
parentdev-python/yarl: add package (diff)
downloadgentoo-c38b5c5cd509f908be6b92cf5ff51736b836e3b8.tar.gz
gentoo-c38b5c5cd509f908be6b92cf5ff51736b836e3b8.tar.bz2
gentoo-c38b5c5cd509f908be6b92cf5ff51736b836e3b8.zip
dev-python/aiohttp: version bump to 1.1.1
Package-Manager: portage-2.3.2
-rw-r--r--dev-python/aiohttp/Manifest1
-rw-r--r--dev-python/aiohttp/aiohttp-1.1.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/aiohttp/Manifest b/dev-python/aiohttp/Manifest
index 72570dcc8857..f8a26d9ca786 100644
--- a/dev-python/aiohttp/Manifest
+++ b/dev-python/aiohttp/Manifest
@@ -2,3 +2,4 @@ DIST aiohttp-0.21.5.tar.gz 529005 SHA256 bac5c883721e0818e405597d2778f08a38cc097
DIST aiohttp-1.0.3.tar.gz 499693 SHA256 5ec0fdf17868bcabfef4effa3ce53c4cfa6108b481585bda88498f46435d5eaa SHA512 1fd915d04bf978826863c06a3a9ef5c23fd11c3b6a65b71828a7be4301e24421483717af6181319ba8461a22351decda4fb776765d18843e4ab1f436f5319d73 WHIRLPOOL 8e6b2503833c98d0d5e341275cc82a0a943e3f69b8b2a0c478c826775aff35b343af6d786b919d75f46a920e09b33eca3d24ba1bec316db82d16a1006cd71e0c
DIST aiohttp-1.0.4.tar.gz 562803 SHA256 7e2d4282b2031ca2aaef35d4291743f37a8840821e8b3c6b491fcd903ad853c0 SHA512 437bed5e5f8729e8809411213cdb8f6a7de08879841c0cc89e88eec6de1883702903ecfb1b8e32ecf3701415fd6757545a0aafd44738681050425d5df44bef56 WHIRLPOOL 4ccb55b93fba2774ea65adcf3b5b00c3bc8bc72f05ac2a07bc84d50dbf07c34b4f3ee75265b800ef59aa9c7deb61e23c7662b3226f8aa0c40918c17295085568
DIST aiohttp-1.0.5.tar.gz 563623 SHA256 053a16d03672cb3055cfac06650d238f55205702207be4a3b40c42333df0ebeb SHA512 f6fe77729a54d817046f0cc952d8906524c2dfe6712dd1972d696680fe34310b6dba9a3b48b6e27c52d3fedd3fa0f541a7c1ac45488b3358e39e3768a01749d9 WHIRLPOOL 51c609bed1bad59e8c1761fa412ed36031da7b80dff03f5edffd84763044cdb570c49d7b9970d133c9b1b224cc293e73004b00447f5b242d91c8286cc21e87c9
+DIST aiohttp-1.1.1.tar.gz 575872 SHA256 6f624d2b340a2c622949e5585540373a86349d31c2f6d46cd4d7b8446cf35f4a SHA512 38636ce4547688ade569ebfc0dbc62b769379500451954c528cd5dddfc7e6c25e6397a56382959ecd43c85c2f344039f4140bf91551e90b288fbd2aefdc94823 WHIRLPOOL d08ba4a51ddb8f66ceed6a64b304192635fccca31f9982484d17f4beaee3cb60d341a3101db6fda8d45231bd99e82ee18b3b86270edbbb9312bd9504f360ac43
diff --git a/dev-python/aiohttp/aiohttp-1.1.1.ebuild b/dev-python/aiohttp/aiohttp-1.1.1.ebuild
new file mode 100644
index 000000000000..58d4e704a8ad
--- /dev/null
+++ b/dev-python/aiohttp/aiohttp-1.1.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+PYTHON_COMPAT=( python3_4 python3_5 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="http client/server for asyncio"
+HOMEPAGE="https://pypi.python.org/pypi/aiohttp"
+SRC_URI="https://github.com/KeepSafe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+EGIT_REPO_URI="https://github.com/KeepSafe/aiohttp"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+CDEPEND="
+ dev-python/async_timeout[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ >=dev-python/multidict-2.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/alabaster-0.6.2[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-asyncio[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-newsfeed[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-spelling[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${CDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/yarl[${PYTHON_USEDEP}]
+ www-servers/gunicorn[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH="${PWD}:${PYTHONPATH}" ${PYTHON} -m pytest tests/ || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}