summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-03-17 21:31:38 +1300
committerKent Fredric <kentnl@gentoo.org>2018-03-17 21:31:38 +1300
commitc3ceb5cbcb9ec3d9b87d1b2625da12db64ec9748 (patch)
treeb96ffabd5f2a3970e134ce4370f133b566279fb8
parentdev-perl/App-pwhich: Restore (~) alpha arm arm64 hppa ia64 ppc ppc64 (diff)
downloadgentoo-c3ceb5cbcb9ec3d9b87d1b2625da12db64ec9748.tar.gz
gentoo-c3ceb5cbcb9ec3d9b87d1b2625da12db64ec9748.tar.bz2
gentoo-c3ceb5cbcb9ec3d9b87d1b2625da12db64ec9748.zip
dev-perl/Tk-TableMatrix: EAPI6 + tests
- EAPI6ify - Enable tests (w/X11) - Update Patch for EAPI6 && git am - Fix DESCRIPTION Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--dev-perl/Tk-TableMatrix/Tk-TableMatrix-1.230.0-r2.ebuild32
-rw-r--r--dev-perl/Tk-TableMatrix/files/Tk-TableMatrix-1.23-makemaker.patch35
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-perl/Tk-TableMatrix/Tk-TableMatrix-1.230.0-r2.ebuild b/dev-perl/Tk-TableMatrix/Tk-TableMatrix-1.230.0-r2.ebuild
new file mode 100644
index 000000000000..f08215ade932
--- /dev/null
+++ b/dev-perl/Tk-TableMatrix/Tk-TableMatrix-1.230.0-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=CERNEY
+DIST_VERSION=1.23
+inherit perl-module virtualx
+
+DESCRIPTION="Create and manipulate tables in Perl + Tk"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-perl/Tk"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-1.23-makemaker.patch" )
+
+src_install() {
+ perl-module_src_install
+
+ # Clean out stray conflicting file - its generated by perl-tk already.
+ # Bug 169294
+ rm "${D}"/${VENDOR_ARCH}/auto/Tk/pTk/extralibs.ld || die
+}
+
+src_test() {
+ virtx perl-module_src_test
+}
diff --git a/dev-perl/Tk-TableMatrix/files/Tk-TableMatrix-1.23-makemaker.patch b/dev-perl/Tk-TableMatrix/files/Tk-TableMatrix-1.23-makemaker.patch
new file mode 100644
index 000000000000..9180e728f312
--- /dev/null
+++ b/dev-perl/Tk-TableMatrix/files/Tk-TableMatrix-1.23-makemaker.patch
@@ -0,0 +1,35 @@
+From 009a27f86c882e229ea8e9cc7efdff9f6f5f751b Mon Sep 17 00:00:00 2001
+From: Matt Chorman <matt@legalizefreedom.org>
+Date: Wed, 21 Jan 2004 03:02:36 +1300
+Subject: Patch issues with newer MakeMaker
+
+Bug: https://bugs.gentoo.org/34940
+Bug: https://bugs.gentoo.org/70000
+---
+ pTk/Makefile.PL | 10 ++++------
+ 1 file changed, 4 insertions(+), 6 deletions(-)
+
+diff --git a/pTk/Makefile.PL b/pTk/Makefile.PL
+index d035029..3d66a0f 100755
+--- a/pTk/Makefile.PL
++++ b/pTk/Makefile.PL
+@@ -234,12 +234,10 @@ sub MY::postamble {
+ my $self = shift;
+ my $dep = $self->Tk::MMutil::mTk_postamble;
+
+-$dep .= $self->dir_target(@{$self->{'dir_targets'}});
+-
+-$dep .= "config :: " . join(" \\\n\t",map($self->catfile($_,".exists"),@{$self->{'dir_targets'}})) .
+- "\n\t".$self->{NOECHO}."\$(NOOP)\n";
+-
+-
++if ($Tk::MMutil::IsWin32 or ($win_arch eq 'MSWin32' and $^O eq 'cygwin'))
++ {
++ my $cc = $Config{'cc'};
++ }
+ $dep . '
+
+ '.$self->{NOECHO}.'$(NOOP)
+--
+2.16.2
+