summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-08-14 18:32:22 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-08-14 19:07:36 +0200
commitc3fc4dd521e3eaa60a0bedf0d2cad8d41901bbb6 (patch)
treeee6d42b4b1268f31da93778ec42f8aa6f34f35bd
parentkde-frameworks/kactivities: 5.85.0 version bump (diff)
downloadgentoo-c3fc4dd521e3eaa60a0bedf0d2cad8d41901bbb6.tar.gz
gentoo-c3fc4dd521e3eaa60a0bedf0d2cad8d41901bbb6.tar.bz2
gentoo-c3fc4dd521e3eaa60a0bedf0d2cad8d41901bbb6.zip
kde-frameworks/kauth: 5.85.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-frameworks/kauth/Manifest1
-rw-r--r--kde-frameworks/kauth/kauth-5.85.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/kde-frameworks/kauth/Manifest b/kde-frameworks/kauth/Manifest
index 26f937bf64c8..55a3b87f06aa 100644
--- a/kde-frameworks/kauth/Manifest
+++ b/kde-frameworks/kauth/Manifest
@@ -1,2 +1,3 @@
DIST kauth-5.82.0.tar.xz 88396 BLAKE2B 1c99917b26f9738b876385276251b7bb616a35bdc82bf581aabba693a0846b8fd615e960dc95829e6a19b158299117988aef10ba965ca16135cbd51c2f4891a5 SHA512 ff69853dbdfee9b22431ee495c07875430015ee706357acdcdfc93b3deca7a373eecf40d30977de97253f044a4dad7548b2ad55c84583b92587a77be285e3ed8
DIST kauth-5.84.0.tar.xz 88588 BLAKE2B 398316b036e51c9dc30f786fd309383ac87af2dd16599d4a3162ab3e5ca92a20be484f8f2b104c0638740e8868257f53d4a1837020024b849953d4be3e26d1dd SHA512 1b7d23e0afbcb2bbf918afaa2461cf0c49ae5f14cfb5243e025a4be5ea9ca4e8c10894267986ffcb3c732819d310d47c5ecd5bd1a0755bf074ad72b680d836bf
+DIST kauth-5.85.0.tar.xz 88580 BLAKE2B bbb6d0d65c3ee0090ee8c7201938ca92cd59d9fbab84c6051b0937d9a6acd8fa3770f11a4e7cff32662c4d6d98296a58960700a87d9359124719be57f893ecaf SHA512 a775f1952ae112fc80a8119dd7060146dd427da6f73d9d3bb308c9683ffa263949e5f06615bc397806e951cf6156631a3d02505edc390c5982732199f17d812d
diff --git a/kde-frameworks/kauth/kauth-5.85.0.ebuild b/kde-frameworks/kauth/kauth-5.85.0.ebuild
new file mode 100644
index 000000000000..b87b08b797b7
--- /dev/null
+++ b/kde-frameworks/kauth/kauth-5.85.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework to let applications perform actions as a privileged user"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="nls +policykit"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ policykit? ( >=sys-auth/polkit-qt-0.113.0 )
+"
+RDEPEND="${DEPEND}"
+PDEPEND="policykit? ( kde-plasma/polkit-kde-agent )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_PythonModuleGeneration=ON # bug 746866
+ $(cmake_use_find_package policykit PolkitQt5-1)
+ )
+
+ ecm_src_configure
+}
+
+src_test() {
+ # KAuthHelperTest test fails, bug 654842
+ local myctestargs=(
+ -E "(KAuthHelperTest)"
+ )
+
+ ecm_src_test
+}