summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-06-09 10:25:41 +0200
committerMichael Palimaka <kensington@gentoo.org>2016-06-17 03:56:24 +1000
commitc52c7146510731bacfa4b96267d3e0c4e8097356 (patch)
treed0a66459d66df6cee895a2eb43a1d2bc05e26b44
parentcmake-utils.eclass: echo ctest arguments (diff)
downloadgentoo-c52c7146510731bacfa4b96267d3e0c4e8097356.tar.gz
gentoo-c52c7146510731bacfa4b96267d3e0c4e8097356.tar.bz2
gentoo-c52c7146510731bacfa4b96267d3e0c4e8097356.zip
kde5-functions.eclass: Improve punt_bogus_dep
The variable holding the min version requirement can be named anything. This should catch most cases, most importantly Qt5 modules.
-rw-r--r--eclass/kde5-functions.eclass2
1 files changed, 1 insertions, 1 deletions
diff --git a/eclass/kde5-functions.eclass b/eclass/kde5-functions.eclass
index 435c8384658a..b20d406721dd 100644
--- a/eclass/kde5-functions.eclass
+++ b/eclass/kde5-functions.eclass
@@ -279,7 +279,7 @@ punt_bogus_dep() {
sed -e "${first},${last}s/${dep}//" -i CMakeLists.txt || die
if [[ ${length} = 1 ]] ; then
- sed -e "/find_package\s*(\s*${prefix}\(\s\+\(REQUIRED\|CONFIG\|COMPONENTS\|\${KF5_VERSION}\)\)\+\s*)/Is/^/# removed by kde5-functions.eclass - /" -i CMakeLists.txt || die
+ sed -e "/find_package\s*(\s*${prefix}\(\s\+\(REQUIRED\|CONFIG\|COMPONENTS\|\${[A-Z0-9_]*}\)\)\+\s*)/Is/^/# removed by kde5-functions.eclass - /" -i CMakeLists.txt || die
fi
}