summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-03-10 00:46:03 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-03-10 00:47:09 -0800
commitc5573f88f5f07123507726c1fb516e6a0b0b440f (patch)
treead1831a3847c0e44e53274b50901999c965a9eb8
parentapp-emulation/docker-compose: mark stable (diff)
downloadgentoo-c5573f88f5f07123507726c1fb516e6a0b0b440f.tar.gz
gentoo-c5573f88f5f07123507726c1fb516e6a0b0b440f.tar.bz2
gentoo-c5573f88f5f07123507726c1fb516e6a0b0b440f.zip
dev-lang/rust: fix boostrap on ppc64
Bug: https://bugs.gentoo.org/679806 Thanks-to: Sergei Trofimovich <slyfox@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--dev-lang/rust/rust-1.32.0.ebuild6
-rw-r--r--dev-lang/rust/rust-1.33.0.ebuild6
2 files changed, 12 insertions, 0 deletions
diff --git a/dev-lang/rust/rust-1.32.0.ebuild b/dev-lang/rust/rust-1.32.0.ebuild
index 06578ddc8bfd..74202f48fd88 100644
--- a/dev-lang/rust/rust-1.32.0.ebuild
+++ b/dev-lang/rust/rust-1.32.0.ebuild
@@ -107,6 +107,12 @@ src_prepare() {
"${WORKDIR}/${rust_stage0}"/install.sh --disable-ldconfig --destdir="${rust_stage0_root}" --prefix=/ || die
+ # ugly hack for https://bugs.gentoo.org/679806
+ if use ppc64; then
+ sed -i 's/getentropy/gEtEnTrOpY/g' "${rust_stage0_root}"/bin/cargo
+ export OPENSSL_ppccap=0
+ fi
+
default
}
diff --git a/dev-lang/rust/rust-1.33.0.ebuild b/dev-lang/rust/rust-1.33.0.ebuild
index c853798a69da..1d6d1dbccc80 100644
--- a/dev-lang/rust/rust-1.33.0.ebuild
+++ b/dev-lang/rust/rust-1.33.0.ebuild
@@ -103,6 +103,12 @@ src_prepare() {
"${WORKDIR}/${rust_stage0}"/install.sh --disable-ldconfig --destdir="${rust_stage0_root}" --prefix=/ || die
+ # ugly hack for https://bugs.gentoo.org/679806
+ if use ppc64; then
+ sed -i 's/getentropy/gEtEnTrOpY/g' "${rust_stage0_root}"/bin/cargo
+ export OPENSSL_ppccap=0
+ fi
+
default
}