summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKyle Elbert <kcelbert@gmail.com>2019-01-26 00:36:52 -0600
committerAlice Ferrazzi <alicef@gentoo.org>2019-01-29 14:58:41 +0000
commitc5bf94fbe98e793c83ffff8615d1ddf93da395e6 (patch)
tree5a055da46a70b638c6e27690779d7780efa8b24a
parentapp-emulation/reg: Remove old (diff)
downloadgentoo-c5bf94fbe98e793c83ffff8615d1ddf93da395e6.tar.gz
gentoo-c5bf94fbe98e793c83ffff8615d1ddf93da395e6.tar.bz2
gentoo-c5bf94fbe98e793c83ffff8615d1ddf93da395e6.zip
dev-util/idea-community: version bump to 2018.3.3 and EAPI 7 port
Bug: https://bugs.gentoo.org/674404 Package-Manager: Portage-2.3.58, Repoman-2.3.12 Signed-off-by: Kyle Elbert <kcelbert@gmail.com> Signed-off-by: Alice Ferrazzi <alicef@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/10905 Signed-off-by: Alice Ferrazzi <alicef@gentoo.org>
-rw-r--r--dev-util/idea-community/Manifest1
-rw-r--r--dev-util/idea-community/idea-community-2018.3.3.183.5153.38.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-util/idea-community/Manifest b/dev-util/idea-community/Manifest
index 6f56feeb5326..bf696dbde77e 100644
--- a/dev-util/idea-community/Manifest
+++ b/dev-util/idea-community/Manifest
@@ -1,2 +1,3 @@
DIST ideaIC-172.3757.52.tar.gz 442963100 BLAKE2B e44f924e279a5b8f2bddbe65cffa24306920fa0f5b85e23b823b1e51fd49e2de2c8953a010b66ea325c4b70ae60268639293b67cd6116f4315ded5e5f6130da1 SHA512 a0178c5ef10aeab527bb8064840c53fff97bf9be468a4e5248b83dba96c5114878f5ff1e20436a67ee488580affa3fb3a2ea627407ed57b87949f64fc1a215d2
DIST ideaIC-183.4588.61.tar.gz 541751086 BLAKE2B 51a5a4dae10d8fd00a0c239f87af3d53b86ffa50f7f9c4f1554265b349d866d60a8994a96f184cc9993fafe12de3dbfa77e3931626436a5f3d3854710b52fb9e SHA512 3e5956353fc0fabbe91b3a946e83b0b3229766a366fdf782c4c017acd7de5a86b3e0cc870a17abe2bdb8b090cb5c58b6c170555f60ba5e6a9a8198073545be87
+DIST ideaIC-183.5153.38.tar.gz 541754349 BLAKE2B 541054736db09c8f0106d5588b224d3033ec21a1e2b566fbc95300fafd39acae5c7f6755082bdb189c5619ed5375ea9fc3e777440d30523a84f864be29e5ad85 SHA512 0bb213da8bffda7d63fa29905d01ee36c3839249dd6e2a58b3941e4317a01bd9315e8bf639f088657938c8197eb2f05fc34fb3e0c49f8c243043cb03f8443f0f
diff --git a/dev-util/idea-community/idea-community-2018.3.3.183.5153.38.ebuild b/dev-util/idea-community/idea-community-2018.3.3.183.5153.38.ebuild
new file mode 100644
index 000000000000..87e485f6d7ff
--- /dev/null
+++ b/dev-util/idea-community/idea-community-2018.3.3.183.5153.38.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils desktop
+
+SLOT="0"
+PV_STRING="$(ver_cut 4-6)"
+MY_PV="$(ver_cut 1-3)"
+MY_PN="idea"
+
+# distinguish settings for official stable releases and EAP-version releases
+if [[ "$(ver_cut 7)"x = "prex" ]]
+then
+ # upstream EAP
+ KEYWORDS=""
+ SRC_URI="https://download.jetbrains.com/idea/${MY_PN}IC-${PV_STRING}.tar.gz"
+else
+ # upstream stable
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://download.jetbrains.com/idea/${MY_PN}IC-${MY_PV}.tar.gz -> ${MY_PN}IC-${PV_STRING}.tar.gz"
+fi
+
+DESCRIPTION="A complete toolset for web, mobile and enterprise development"
+HOMEPAGE="https://www.jetbrains.com/idea"
+
+LICENSE="IDEA
+ || ( IDEA_Academic IDEA_Classroom IDEA_OpenSource IDEA_Personal )"
+IUSE="-custom-jdk"
+DEPEND="!dev-util/${PN}:14
+ !dev-util/${PN}:15"
+RDEPEND="${DEPEND}
+ >=virtual/jdk-1.7:*"
+S="${WORKDIR}/${MY_PN}-IC-${PV_STRING}"
+
+QA_PREBUILT="opt/${PN}-${MY_PV}/*"
+
+src_prepare() {
+ if ! use arm; then
+ rm bin/fsnotifier-arm || die
+ fi
+ if ! use custom-jdk; then
+ if [[ -d jre64 ]]; then
+ rm -r jre64 || die
+ fi
+ fi
+ eapply_user
+}
+
+src_install() {
+ local dir="/opt/${PN}-${MY_PV}"
+
+ insinto "${dir}"
+ doins -r *
+ fperms 755 "${dir}"/bin/{format.sh,idea.sh,inspect.sh,printenv.py,restart.py,fsnotifier{,64}}
+
+ if use custom-jdk; then
+ if [[ -d jre64 ]]; then
+ fperms 755 "${dir}"/jre64//bin/{java,jjs,keytool,orbd,pack200,policytool,rmid,rmiregistry,servertool,tnameserv,unpack200}
+ fi
+ fi
+
+ make_wrapper "${PN}" "${dir}/bin/${MY_PN}.sh"
+ newicon "bin/${MY_PN}.png" "${PN}.png"
+ make_desktop_entry "${PN}" "IntelliJ Idea Community" "${PN}" "Development;IDE;"
+
+ # recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
+ mkdir -p "${D}/etc/sysctl.d/" || die
+ echo "fs.inotify.max_user_watches = 524288" > "${D}/etc/sysctl.d/30-idea-inotify-watches.conf" || die
+}