summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-03-24 18:55:40 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-03-24 19:06:54 -0500
commitc6af79ce25cde237c25f86de1395a598b211d2bc (patch)
tree87063d6ec593bc5c35b353302a9ead8a16ac5883
parentdev-python/oslo-versionedobjects: remove pike/queens (diff)
downloadgentoo-c6af79ce25cde237c25f86de1395a598b211d2bc.tar.gz
gentoo-c6af79ce25cde237c25f86de1395a598b211d2bc.tar.bz2
gentoo-c6af79ce25cde237c25f86de1395a598b211d2bc.zip
dev-python/oslo-utils: remove pike/queens
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--dev-python/oslo-utils/Manifest1
-rw-r--r--dev-python/oslo-utils/oslo-utils-3.35.1.ebuild95
2 files changed, 0 insertions, 96 deletions
diff --git a/dev-python/oslo-utils/Manifest b/dev-python/oslo-utils/Manifest
index 31eabc4f4c8b..6c2307872655 100644
--- a/dev-python/oslo-utils/Manifest
+++ b/dev-python/oslo-utils/Manifest
@@ -1,2 +1 @@
-DIST oslo-utils-3.35.1.tar.gz 85615 BLAKE2B c2eea32d6844c59425a6e8783c1285dc47f2863401e6739bd7418c23ad1446613f41cbcd2e2d85d260ff8adddb681d9f1b5547ac521c2d9b5e2050324457bf97 SHA512 069fd262cfab3f5756b1135552c19c886fdbf72885f12b2ae84c67af1f50306ccc2c5331b1774fc49fb764107ad1c3e94305cd6fb6a25888ee8fa446facd2cbc
DIST oslo-utils-3.36.4.tar.gz 87872 BLAKE2B 15f4fe90e5335cdf146ec582a506f2ab2bcae9989feca24caec7c12a4136767e93acb117345ce62013cde64938994eeb0c0809665cd155d5e0aaae7dc6aad879 SHA512 d5a81b68cc00c25eeb2e6d39b8fd4a47cb958c32e50471845b14a06cb5f420ac58986106893a27364adba968adc19f864624d69bae316202bdaf2c156458eac1
diff --git a/dev-python/oslo-utils/oslo-utils-3.35.1.ebuild b/dev-python/oslo-utils/oslo-utils-3.35.1.ebuild
deleted file mode 100644
index 1c2d39f41d76..000000000000
--- a/dev-python/oslo-utils/oslo-utils-3.35.1.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1 vcs-snapshot
-
-MY_PN=${PN/-/.}
-
-DESCRIPTION="Oslo Utility library"
-HOMEPAGE="https://launchpad.net/oslo"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="doc test"
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- test? (
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
- >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
- >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
- >=dev-python/ddt-1.0.1[${PYTHON_USEDEP}]
- >=dev-python/coverage-4.0.0[${PYTHON_USEDEP}]
- !~dev-python/coverage-4.4.0[${PYTHON_USEDEP}]
- >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
- >=dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
- )
- doc? (
- >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
- !~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
- >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
- >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
- virtual/python-funcsigs[${PYTHON_USEDEP}]
- >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
- >=dev-python/monotonic-0.6[${PYTHON_USEDEP}]
- >=dev-python/pytz-2013.6[${PYTHON_USEDEP}]
- >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
- >=dev-python/netifaces-0.10.4[${PYTHON_USEDEP}]
- >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
- >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
-"
-
-python_prepare_all() {
- sed -i '/^hacking/d' test-requirements.txt || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && esetup.py build_sphinx
-}
-
-# Note: Tests fail due to requiring installation
-#
-# Installation appears to fail due to the use of namespace packages but root
-# cause was never truly established.
-#
-# Tests fail with:
-# ImportError: No module named 'oslo.utils
-
-#RESTRICT="test"
-
-python_test() {
- distutils_install_for_testing
-
- cd "${TEST_DIR}"/lib || die
-
- rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPTYHON}"
-
- testr init || die "testr init failed under ${EPYTHON}"
- testr run || die "testr run failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/build/html/. )
-
- distutils-r1_python_install_all
-}